Mozilla doesn't preserve the original "Last-Modified" date sent by the server when downloading a file

VERIFIED DUPLICATE of bug 178506

Status

enhancement
VERIFIED DUPLICATE of bug 178506
16 years ago
2 years ago

People

(Reporter: filamento, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Most servers send an HTTP header called "Last-Modified:" which informs about
when was the last time a file was modified. However, Mozilla ignores this header
and always sets the "Last modified" property of the file to be the current
system date.

Could you please add an option (maybe a hidden one, if you prefer) to preserve
the server's last-modified date?

Thank you very much.


Reproducible: Always

Steps to Reproduce:
1. Go to any webpage
2. Download any file
3. Check the file's "last-modified" date in Windows Explorer

Actual Results:  
The file's "last modified" date was incorrectly set to be the current date.

Expected Results:  
Mozilla should have preserved the file's "last-modified" date specified by the
server.
We could probably do this if we could get the last-modified date off the channel
in a useful format (not as a string) or if there were an easy way to convert
said string to a date....  If there isn't, it's not worth it.

Even if we can do this, is it desirable?  Ben?  Thoughts?

*** This bug has been marked as a duplicate of 178506 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.