mozilla-xremote-client "mailto()" returns failure, but makes Firefox try to launch the mail program

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
a year ago

People

(Reporter: Anders Kaseorg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031206 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031206 Firebird/0.7+

I'm using the 2003-12-06-09-trunk gtk+xft2 Linux build. I also use (well, am
trying to use) Thunderbird 0.4 as my mail program, although Thunderbird doesn't
directly affect this bug.

When Firebird is running and Thunderbird is not,
  mozilla-xremote-client "mailto(me@example.com)"
exits with status 3, indicating failure, as it should. However, Firebird still
gets the command, and tries to launch the system default mail program.

This is particularly bad if the system default mail program is a Thunderbird
wrapper script that contains the above command (xremote || launch a new
thunderbird) -- it leads to an infinite loop creating thunderbird windows!

Reproducible: Always

Steps to Reproduce:
1. Start Firebird.
2. mozilla-xremote-client "mailto(me@example.com)"


Actual Results:  
Exit status 3, but Firebird launches the mail program.

Expected Results:  
Exit status 3, and nothing happens, so the script that called xremote can detect
failure and launch the mail program itself.
(Reporter)

Comment 1

14 years ago
I suspect this report is being ignored, because everyone was excluded when I
sent it... :-(
(Reporter)

Comment 2

14 years ago
Can somebody look at this please? It makes the Firebird/Thunderbird combo
virtually useless since there's no way to stop them from interfering with each
other!
Severity: normal → major
(Reporter)

Updated

14 years ago
Severity: major → critical

Comment 3

14 years ago
I confirm this bug with Linux Firefox 0.8 and Thunderbird 0.5+.
It has just DOSed my machine by launching an infinite number of Thunderbird windows.

Comment 4

14 years ago
(In reply to comment #3)
> I confirm this bug with Linux Firefox 0.8 and Thunderbird 0.5+.
> It has just DOSed my machine by launching an infinite number of Thunderbird
windows.

In my case, if thunderbird is not running it works fine, but if thunderbird is
running and I call it with -remote from firefox I have to "pkill thunderbird" in
a real hurry as my window manager gets taken over by many compose windows
(spawning about 1 per second). This is in the current version of fluxbox.

Run script is:


export MOZILLA_FIVE_HOME=/opt/thunderbird
MT="$1"
shift
SJ="$2"
shift

if [ $(ps aux | grep thunderbird | wc -l) -gt 4 ]
then
        # thunderbird is running
        $MOZILLA_FIVE_HOME/thunderbird -remote "mailto($MT?subject=$SJ$@)"
else
        # thunderbird is not running
        $MOZILLA_FIVE_HOME/thunderbird -P default -compose mailto:$MT?subject=$SJ$@
fi 


sarahweb -AT- walters -d0t- id -d0t- au

Comment 5

14 years ago
duplicates bug 237325?

Comment 6

14 years ago
Is this still a problem with the latest branch release or nightly build?
(Reporter)

Comment 7

14 years ago
With the current branch nightly, mozilla-xremote-client -a firefox
'mailto(me@example.com)' gives:
  ./mozilla-xremote-client: Error: Failed to send command: 509 internal error
This can't be a good thing.
With firefox 1.0 PR and thunderbird 0.8, the problem persists as described in
comment #7. Send link and mailto: anchors are not usable through firefox...
Summary: mozilla-xremote-client "mailto()" returns failure, but makes Firebird try to launch the mail program → mozilla-xremote-client "mailto()" returns failure, but makes Firefox try to launch the mail program

Updated

12 years ago
Blocks: 281847

Comment 9

12 years ago
mailto:  anchor on webpages under firefox browser does not bring up an email Thunderbird screen under FreeBSD 6 Unix OS. 

These Mozilla apps should be compatable, right?

Anyone know how to fix this?
Assignee: bross2 → nobody
QA Contact: general

Comment 10

a year ago
Is this relevant anymore? If not, please close.
(Reporter)

Comment 11

a year ago
As of bug 1080319, mozilla-xremote-client no longer exists.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.