If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Invalid URL, which has no DNS entry, will cause Firebird to launch dial-up connection, even though already connected to DSL

RESOLVED DUPLICATE of bug 186665

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 186665
14 years ago
14 years ago

People

(Reporter: Robert Marshall, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031207 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031207 Firebird/0.7+

Even though you are connected to a DSL connection, if you mistype a URL, and
whatever you entered does not have a DNS entry somewhere, a Dial-up connection
window will pop up.  I used http://189888.at in my test. 

Reproducible: Always

Steps to Reproduce:
1. Establish connection to Internet
2. Open Firebird browser
3. Type an invalid URL (I used http://189888.at for my test)
4. Hit enter

Actual Results:  
After a few seconds the Dial-Up Network Coneection window will pup up, asking me
to connect to my ISP. After I hit cancel, an alert window pops up that says,
"http://189888.at could not be found. Please check the entry and try again."

Expected Results:  
Since you are already connected to the Internet, you should only get the Alert
error msg that I noted at the end of the Actual Results section above.

The same behaviour happens if you enter in a directory and/or machine name (i.e:
"Q:" or "/RMARSHALL-DESKTOP/Q")

In Internet Explorer, the browser will bring up http://search.msn.com, informing
you that "We can't find http://189888.at", giving you several possible pages
that are close to what your data showed, and with a window where you could do an
MSN Search. Netscape brings up a search engine as well, though I forget which
one, and I don't have Netscape installed anymore to test.
See the bug 186665 comment 5 for details on how to turn the autodialer off in
Windows.

*** This bug has been marked as a duplicate of 186665 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.