Linux 1.6b, recent nightlies compiled with gcc 3.2, g++ 2.96

VERIFIED FIXED

Status

SeaMonkey
Build Config
--
major
VERIFIED FIXED
14 years ago
3 years ago

People

(Reporter: Bob Lockie, Assigned: dbaron)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031208

# LoadPlugin: failed to initialize shared library
/usr/local/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
[/usr/local/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so:
undefined symbol: _ZdlPv]

Reproducible: Always

Steps to Reproduce:
1. run mozilla

Actual Results:  
an error is printed on the console.

Expected Results:  
the java plugin should load.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 205205 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
Not a duplicate; this is a new issue.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

14 years ago
A comment in bug 205205 led me to download linux nightly 2003120915 and check
its about:buildconfig page. According to the page, this nightly was compiled
with gcc 3.2  and g++ 2.96. This will cause problems for people who have
switched to using the gcc 3.2-specific version of the java plugin.
Assignee: peterlubczynski-bugs → nobody
Status: UNCONFIRMED → NEW
Component: Plug-ins → Build Config
Ever confirmed: true
QA Contact: build-config
Summary: java - LoadPlugin: failed → Recent nightlies compiled with gcc 3.2, g++ 2.96

Comment 4

14 years ago
Created attachment 137195 [details]
about:buildconfig (content/global/buildconfig.html) from linux 2003120916

Comment 5

14 years ago
*** Bug 227955 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
On further inspection, the linux release of 1.6b was also built this way.
Summary: Recent nightlies compiled with gcc 3.2, g++ 2.96 → Linux 1.6b, recent nightlies compiled with gcc 3.2, g++ 2.96

Comment 7

14 years ago
*** Bug 228068 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 227984 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

14 years ago
I really should have looked at about:buildconfig, shouldn't I.
Assignee: nobody → dbaron

Comment 10

14 years ago
Just for the record (and at the risk of stating the obvious) it works with the
non gcc32.

Comment 11

14 years ago
*** Bug 228092 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

14 years ago
Could those of you who are interested test the build at:

http://mozilla.oregonstate.edu/pub/mozilla.org/mozilla/tinderbox-builds/comet/
(That's the one of the ftp.mozilla.org mirrors that I know has updated already.)

This was a mistake.  Please don't encourage people to switch plugins back
because they'll just have to switch forward again.

Comment 13

14 years ago
And just for the record again, everything works the way it should with the build
that was suggested, with the gcc32 version.

Comment 14

14 years ago
Just tried the build at
http://mozilla.oregonstate.edu/pub/mozilla.org/mozilla/tinderbox-builds/comet/
as suggested (buld 20031210)
It works correctly with the ns610-gcc plugin.
about:builds gives both gcc and c++ as gcc version 3.2.3

Comment 15

14 years ago
*** Bug 228191 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
All seems well with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031212 MultiZilla/1.6.0.0c
Product: Browser → Seamonkey
(Assignee)

Comment 17

10 years ago
I think this was fixed long ago.
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → FIXED

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 227972
You need to log in before you can comment on or make changes to this bug.