Recurrence event overlap does not display well in day / week view

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Andree Jacobson, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031110
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031110

If an event is defined as recurring, and then another event in a different
calendar overlaps that event, the two events are not aware of eachother and will
not divide the space between them but completely overlap.

Reproducible: Always

Steps to Reproduce:
1. Create new calendar: Test1
2. Create new calendar: Test2
3. Create new event in Test1, TestEvent1 (on a monday, 11:00 - 13:00)
4. Set TestEvent1 to be recurring each day for 5 days (i.e. through the week)
5. Create new event in Test2, TestEvent2 (on wednesday that save week) from
12:00 - 14:00)
6. Change to day view for Wednesday

Actual Results:  
The two events are overlapping in the day and week view.

Expected Results:  
It should have divided the space available for each appointment since they are
overlapping and there is plenty of space to display both individually. (See what
happens if two appointments as defined above are created on wednesday, without
either one being recurring from an earlier appointment)

Comment 1

14 years ago
This is actually not dependant on the events being in different calendars.

There are other problems (maybe related) in day/week view event drawing - try
setting three events like this:
------
|    | 
|    |  ------
|    |  |    |
------  |    |
        |    |
------  |    |
|    |  |    |
|    |  ------
|    |
------

The result is this:
-----
|   | 
| -----
| |   |
--|   |
  |   |
----- |
|   | |
|   |--
|   |
-----

I'll see if I can come up with a better event placing function. 

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

14 years ago
I have a similiar comportement on recurring events.

Build: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Event1: 09:00 -> 12:00 starting 03/23/04, every day forever
Event2: 11:00 -> 14:00 starting 03/23/04, every day forever

Daily on weekly view show the same result.
On 03/23/04 the two events are showing well, there is no overlap.
On 03/24/04 (and following days) the two events are both using all space and
therefore overalp totally and not just half as described above.

Comment 3

14 years ago
Good news on this one: All examples mentioned will be fixed when the patch in
bug 236551 gets checked in.

Comment 4

14 years ago
Created attachment 146288 [details] [diff] [review]
fixes event overlap problem for week view

Day view problems have been taken care of in bug 236551. This patch copies the
changes to week view.

Updated

14 years ago
Attachment #146288 - Flags: first-review?(mostafah)
(Assignee)

Comment 5

14 years ago
Comment on attachment 146288 [details] [diff] [review]
fixes event overlap problem for week view

r=mostafah
Checked in.
Thanks
Attachment #146288 - Flags: first-review?(mostafah) → first-review+
Looks like this should have been resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.