Pref to disable animated images

RESOLVED WONTFIX

Status

()

Firefox
Preferences
--
enhancement
RESOLVED WONTFIX
15 years ago
12 years ago

People

(Reporter: Steve Shockley, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031201 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031201 Firebird/0.7+

In Mozilla and IE, I can disable animated GIFs and/or have them loop only once.
 I can't find a way to do that in Firebird.  I did find a bug related to hitting
ESC to stop the animations, but nothing about setting a preference to never show
animations.  I hate blinky things.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Mozilla should give the user an option to disable animated graphics.

Comment 1

15 years ago
Yeah, this would be a nice feature. I too hate flashy animated GIFs. There would
need to be some visual sign that it is animated and a way to show the full
thing, just in case it's something you actually want to see.

In fact, if someone can give me some documents on how to create extensions, I
would be willing to give this a go.

Comment 2

15 years ago
See also bug 213377, "Cannot stop animation with stop button or escape key".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Unable to disable animated GIFs → Pref to disable animated images
the pref still exists, it just doesn't have UI

http://www.gerbilbox.org/newzilla/mozilla/usingmoz10.php#prefs gives info on the
pref and how to set it (about:config works too).  This would make a good
extension for those people who care enough, try google for xfly and read the docs :)

Before anyone decides to reopen this, please read
http://www.mozilla.org/projects/firebird/ue/philosophy/realities.html and
explain why this function belongs in the core of a mass-market browser.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
Thanks for that link, now I have about:config to play with :D.

As for the extension, I'll give it a go, I figure it should be a relatively easy
one to do for a first one...

Comment 5

15 years ago
*** Bug 231262 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
*** Bug 259779 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Having an UI for this is a must. Animated images can get very annoying, and
we're trying to give users a better browsing experience, not a worse one. Users
are going to miss this preference, since both IE and Mozilla do have it.
Just because browser X has a pref doesn't mean that users are going to miss it.
 I would suggest that the majority of users don't know it exists, being that its
buried on IE deep in the Advanced pane.  (Based especially on a number of
usability studies that conclude that users don't go into options).

As a more practical matter, unless this could be made to apply to animated Flash
ads (now by far the majority out there) its just going to appear broken, unless
the user is sophisticated enough to right click and determine that its Flash,
not an animated GIF.  I don't think that's a reasonable expectation of a user,
especially given that most users don't right-click.

Ani-GIFs are such a small proportion of the animated images (yes, Flash is an
image from a user perspective) that are used on major sites that this pref is
obscure at best, and is more likely to confuse than aid users.
*** Bug 259971 has been marked as a duplicate of this bug. ***
*** Bug 270821 has been marked as a duplicate of this bug. ***
*** Bug 275230 has been marked as a duplicate of this bug. ***
*** Bug 282122 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.