Closed Bug 227922 Opened 17 years ago Closed 11 years ago

Add a new entry in the context menu of selected text: Open URL

Categories

(Firefox :: Menus, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 454518

People

(Reporter: ryde, Unassigned)

References

Details

(Keywords: uiwanted)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: 

It is anoying when a URL is not a link, only written in text.
You have to (depending on OS): Select text, Copy text, Open new window/tab,
Point to location bar, Paste text, Press Enter.

It would have been very convenient to have a context entry that does all this
instead, similar to the context websearch feature.

Reproducible: Always

Steps to Reproduce:
See also bug 10080, same bug for Seamonkey.
Should use function from bug 116242.
Depends on: 116242
Is it really necessary to keep every bug twice, for Firebird and Seamonkey?
Confirming enhancement request.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file Code to apply
Confirming enhancement request.
I've coded the enhancement and it works OK. But it's the first time that I'm
doing this kind of stuff, so I don't really know how to make a patch yet. So
I'm attaching a plain document with the few lines that have to be added to
corresponding files. I hope it'll be of use.
If you select the word "Comments" above, there is a context menu 'Search Web for
"Comments"'

So, after selecting an URL, the context menu entry could be 'Open
"bugzilla.mozill..." in New Window' and the full URL could appear in a tooltip.
Removing bug 116242 as dependancy:
a) if bug 116242 is fixed then a fix for this bug is not needed
b) similarly, the reporter is asking for a link function on the menu precisely
for when the text in question is not a detected as a link (for whatever reason)
or is an otherwise non-obvious link

Note however, Bug 10080 for suite suggests relying on extensions for this
suggested functionality.  Perhaps both should be marked as WONTFIX?

On the chance that it won't, setting keyword -> helpwanted  for someone to
implement stephan's suggested fix
No longer depends on: 116242
Keywords: helpwanted
hmm, rereading for 5th time - if 116242 is needed after the text is selected to
invoke it as a URL then I was wrong to remove as blocker.  Seems
counterintuitive though.  If I'm wrong please reset. 
Assignee: firefox → nobody
QA Contact: bugzilla → menus
*** Bug 312032 has been marked as a duplicate of this bug. ***
Does any plugin add this feature?
(In reply to comment #10)
> Does any plugin add this feature?
> 
Yes, there is a "Linkification" plugin that converts the selected text to a link. This requires "selection + right-click + left-click" to make it a link, then left click again to open it. Instead of a simple "selection +  right-click"...
Duplicate of this bug: 394327
You could also grab the code from text/plain 1.1.8 here: http://mozilla.durys.net/textplain/
Duplicate of this bug: 236336
Duplicate of this bug: 421021
Duplicate of this bug: 423343
Blocks: 433195
why you dont implement it in the core? It is so simple and you are still forgoting that you lost peoples which dont know the extension (mentioned one abowe is very old and for FF2, maybe it is working with FF3 but who knows) and need this future. I dont beleave that you will not use it
This is Plain Text Links 0.3.1, which is just Ted Mielczarek's PlainText Links 0.3 extension 'made compatible' with Fx up to 4.0.

Original extension:
http://ted.mielczarek.org/code/mozilla/textlink/

"Features:

    * Right click on plain text links, open like any other link
    * Automatic fixup of URLs, including handling of common obscurations such as "hxxp://"
    * Correctly handles URLs surrounded by quotes or parentheses, and URLs at the end of a sentence containing a trailing period
    * Does not send a referrer header for visited links"

And he forgot to mention:
    * Opens  fxxp:// links
    * Supports middle-click -> opens URL in new tab
    * No need to select the whole link; just hover the mouse pointer over the link -> right-click -> Open selected URL
   * Supports multi-line (word-wrapped) URLs
   * Correctly handles URLs surrounded by blank spaces/indents


I think something like this would be a good implementation of "Open plain-text links as URLs", since it's both easy-to-use and powerful.
Duplicate of this bug: 512644
Flags: blocking-firefox3.6?
worcester, you know better than to ask for blocking for a feature addition this late in the game. If you keep doing this, I'll remove your canconfirm bugzilla privs.

FWIW, I don't think we should do this as a context menu entry only, either. I don't see the point in there being a URL that isn't treated as a link.

Adding uiwanted to get some input, but this will need a browser peer for review.
Flags: blocking-firefox3.6? → blocking-firefox3.6-
Keywords: helpwanteduiwanted
> I don't see the point in there being a URL that isn't treated as a link.

This an be very intentional by the website. There have been lawsuits to high courts in Germany which made journalistic websites responsible for links to illegal companies like slysoft.com, but not for merely reporting about things related to them. So, heise.de since then no longer links URLs which may be problematic, given that the court made this specific distinction between linking and reporting. However, they may say "slysoft.com" as normal text, because that may be the company name (in some cases, not this). If browsers turn that into a link, courts will be pragmatic and consider that a link, because it's indistinguishable by the user and has the same effect, and give trouble to the site again.

Added to that are performance problems. There's an inherent cost to processing all text and checking it for links.
Depends on: 454518
Isn't this a duplicate of bug 454518?
Seems like it. The option was added anyhow, so duping...
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454518
I do not think this is a duplicate of bug 454518.

The intent of this bug is to allow any selected text to be treated as a URL via the context menu.  Essentially, I can highlight the text flickr.com and open this in a new tab.  

As I understand it, this is quite different Bug 454518, which only addresses the case where the protocol is present in the URL e.g. http://flickr.com - which is quite a different thing.
That was addressed by bug 515512, so either way this is fixed already. If you'd rather dupe it to that bug, feel free...
You need to log in before you can comment on or make changes to this bug.