RFE: Update Calendar to use Qute style icons

RESOLVED WONTFIX

Status

Calendar
Sunbird Only
--
enhancement
RESOLVED WONTFIX
14 years ago
11 years ago

People

(Reporter: Kenneth, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(7 attachments, 7 obsolete attachments)

45.98 KB, image/png
Details
15.94 KB, image/png
Details
5.47 KB, image/png
Details
33.86 KB, patch
Details | Diff | Splinter Review
37.87 KB, patch
Details | Diff | Splinter Review
2.59 KB, patch
Details | Diff | Splinter Review
15.62 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030917 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030917 Firebird/0.6.1+

Calendar should evolve to using the style and techniques used in the *Bird
implementations, including a new "Qute" style theme and methodology.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

14 years ago
Hi Kenneth,
So I guess the plan would be to provide a new skin directory with all the
appropriate files.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
Created attachment 137113 [details]
calendar.css (modified lines - 49-331; 398-445)
(Reporter)

Comment 3

14 years ago
Created attachment 137115 [details]
calendar.xul - (modified lines 415-450)
(Reporter)

Comment 4

14 years ago
Created attachment 137116 [details]
monthView.xul (modified lines 76, 108)
(Reporter)

Comment 5

14 years ago
Created attachment 137117 [details]
calendar-toolbar.png (created directory "icons" in classic for this)
(Reporter)

Comment 6

14 years ago
Created attachment 137118 [details]
calendar-toolbar-small.png (created directory "icons" in classic for this)
(Reporter)

Comment 7

14 years ago
Created attachment 137119 [details]
prevnextarrow.png (created directory "icons" in classic for this)
(Reporter)

Comment 8

14 years ago
This is my first attempt to properly use Bugzilla, so I may need some coaching
as I use the system.  Basically all of the attached files (posted 2003-12-09)
are modifications to begin converting Calendar to the "Qute" style.  Eventually,
ideally, all icons will go into the "icons" directory and the structure will
become more like TB and FB.

The icons here are mostly from the existing set, with some existing ones from
Qute pulled from the browser.  Both regular sized and small toolbar icons are
included, although I do not know how to add the toolbar customization to choose
small icons.

Also, ideally the modified lines in calendar.css would go in an external file
(primaryToolbar.css) and be imported into calendar.css.  But again, I'm not
knowledgable enough to do this just yet.

Updated graphical icons for the Qute style to come as I'm able to do them, or I
would encourage someone else with further experience in icon creation to step up
to help.

Modified files:
calendar.css
monthView.xul
calendar.xul

Deleted:
btn1.gif
btnwm1.gif
btn1.png
prevnextarrow.png

Created:
icons/
icons/calendar-toolbar.png
icons/calendar-toolbar-small.png
icons/prevnextarrow.png

Comment 9

14 years ago
Created attachment 137126 [details] [diff] [review]
patches to calendar xul files

this is a patch that corresponds to the changes made in calendar.xul and
monthView.xul
(Assignee)

Comment 10

14 years ago
Comment on attachment 137126 [details] [diff] [review]
patches to calendar xul files

Please provide patches using cvs code, otherwise they won't have any use.
Attachment #137126 - Attachment is obsolete: true

Comment 11

14 years ago
Created attachment 137127 [details] [diff] [review]
changes to calendar.css

these are the changes to calendar/resources/skin/classic/calendar.css
(Assignee)

Comment 12

14 years ago
Comment on attachment 137127 [details] [diff] [review]
changes to calendar.css

Please provide patches using cvs code, otherwise they won't have any use
Attachment #137127 - Attachment is obsolete: true

Comment 13

14 years ago
Created attachment 137133 [details] [diff] [review]
patches to calendar xul files

this is a patch that corresponds to the changes made in calendar.xul and
monthView.xul, on latest CVS

Comment 14

14 years ago
Created attachment 137134 [details] [diff] [review]
changes to calendar.css

these are the changes to calendar/resources/skin/classic/calendar.css (from
latest cvs)

Comment 15

14 years ago
Sorry, patches were against MOZILLA_1_5_BRANCH. (I did a cvs update but didn't
realise I had a tag), have updated...
(Assignee)

Comment 16

14 years ago
kenneth: Any reason you changed the "id"s of the icons? If not can you just use
the old names to minimize the changes?
(Assignee)

Comment 17

14 years ago
Kenneth is not getting emailed as comments are added. Ccing him to see if it works.
(Assignee)

Comment 18

14 years ago
kenneth: Are you using the latest code from CVS? Please do so, because your
proposed changes are backing out some fixes recently made to the code.
Example:

 .week-view-event-class[eventselected="true"]
 {
-   background-color     :  #D5E3F2;  
-   border	        : 2px solid #990000;
+   background-color  : #D5E3F2;
+	border				: 1px solid #003366;
 }

which was fixed for bug 210236 here( see bottom ):
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=calendar.css&branch=&root=/cvsroot&subdir=mozilla/calendar/resources/skin/classic&command=DIFF_FRAMESET&rev1=1.43&rev2=1.44
(Reporter)

Comment 19

14 years ago
Honestly I wasn't using the code from the CVS.  I've yet a great deal to learn 
about the process and am reading the Hacking Mozilla section of the site now.  
Originally this started out as just my tweaking Eric Belhaire's Calendar for 
Thunderbird code.

Thanks for the advice,
Kenneth

Comment 20

14 years ago
The rabbit hole is deep, but also very rewarding... ;)
(Reporter)

Comment 21

14 years ago
Created attachment 137263 [details] [diff] [review]
Updated calendar.css, modified from file from CVS

I've made my changes to the file from the CVS.	Also, to address the comment
about why I changed the button names, it was to remain consistent with the
style in which Thunderbird/Firebird are done.  It could easily be changed back
if this isn't kosher with folks.

Thanks,
Kenneth
(Reporter)

Updated

14 years ago
Attachment #137113 - Attachment is obsolete: true
(Reporter)

Comment 22

14 years ago
Created attachment 137264 [details] [diff] [review]
Calendar.xul, modified from the CVS
Attachment #137115 - Attachment is obsolete: true

Comment 23

14 years ago
Created attachment 137290 [details] [diff] [review]
patches to calendar.xul

updated patch for calendar.xul based on latest CVS

Updated

14 years ago
Attachment #137133 - Attachment is obsolete: true

Comment 24

14 years ago
Created attachment 137291 [details] [diff] [review]
changes to calendar.css

changes to calendar.css updated from latest CVS. Does not include name changes
any more
Attachment #137134 - Attachment is obsolete: true

Comment 25

14 years ago
Kenneth, should the monthView.xul attachment be obsoleted, seeing as those
changes aren't included in calendar.css anymore?
(Assignee)

Comment 26

14 years ago
Question: Where are the "small" toolbar icons supposed to show up? Applying the
patch I get the big Qute icons for the main toolbar but I don't know where to
look for the small ones.
Also I have problems with the prev and next arrows ( they all show up ). It
might just be me though.
(Reporter)

Comment 27

14 years ago
Comment on attachment 137116 [details]
monthView.xul (modified lines 76, 108)

This is obsolete as the month change has gone back to the old method
Attachment #137116 - Attachment is obsolete: true
(Reporter)

Comment 28

14 years ago
Responding to #26... this is for a later implementation of the customazible 
toolbar used in Firebird and Thunderbird.  I have no idea at this stage how it 
is done, but ideally it would include this similar functionality at some 
point.  That way we have that much work out of the way.

Ken

Comment 29

14 years ago
Sipaq on the Mozillazine forums has requested work to be done on revising the
classic theme for Sunbird. I am doing this work (with the help of a graphic artist).

With the theme changes for Firefox and Thunderbird, the theme for Sunbird will
not be using Qute style graphics. Therefore, should this bug be WONTFIXed and a
new bug be created for the theme revision? I don't see an existing bug for the
theme work but I have some questions and would like some guidance.
-> WONTFIX
Like Chris said, we're looking for a totally new theme, though that may even be
a    Qute-like theme if Mostafah says so. 

Chris please open a new bug for the new theme contest and please CC me on that bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.