Text is moving/shaking sideways

RESOLVED DUPLICATE of bug 215341

Status

Core Graveyard
GFX: Gtk
--
trivial
RESOLVED DUPLICATE of bug 215341
15 years ago
10 years ago

People

(Reporter: Lutz Feldgen, Assigned: blizzard)

Tracking

({testcase})

Trunk
x86
Linux
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

On the specified page the text is moving (better: shaking), probably depending
on action-smileys. Mozilla 1.0.1 has no problems as well as IE.
Just watch the given page a while with Mozilla in default size!
Resizing to other sizes removes the behaviour!

Reproducible: Always

Steps to Reproduce:
1.Leave Mozilla in default size
2.Goto above link
3.watch the text parts moving/shaking

Actual Results:  
Text was moving/shaking

Expected Results:  
Display non-moving text

Comment 1

15 years ago
Lutz,  what is your "Display resolution" preference set to?
(under Preferences->Appearance->Fonts),  I'm guessing "System setting" - 
in that case, please run the "xdpyinfo" command in a shell window and report
the value it prints for "resolution".  Finally, if you change the Mozilla
preference "Display resolution" to "96 dpi" and then *restart Mozilla* does
the "shaking" stop after that?

Comment 2

15 years ago
Created attachment 137148 [details]
Testcase

Updated

15 years ago
Assignee: other → blizzard
Status: UNCONFIRMED → NEW
Component: Layout → GFX: Gtk
Ever confirmed: true
Keywords: testcase
I see this with the testcase, and I've been seeing it when selecting text on
tinderbox.  116dpi.

Comment 4

15 years ago
Pending answer from Reporter - it's a dupe of bug 215341
(It only occurs when system dpi != 96)
I suspect this is a rounding problem of some sort combined with the fact that
we're unioning all the invalidate rects.
(Reporter)

Comment 6

15 years ago
Preferences - Apperarance - Fonts is set to "System Setting",
xpdyinfo resolution is 90 x 89 dots per inch.

When setting to 96 dpi its gone as proposed.

Comment 7

15 years ago
Thank you.

*** This bug has been marked as a duplicate of 215341 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.