pageup/pagedown do not work inside frameset.

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: john russell, Assigned: Aaron Leventhal)

Tracking

({qawanted})

Trunk
x86
Windows 98
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208

pages that are called from a frameset do not allow page down 
to function. the same pages when accessed directly do scroll using
pageup page down.
demo is home.cogeco.ca/~ve3ll/index.html  --- frames
        home.cogeco.ca/~ve3ll/home.htm    --- direct (no frame)


Reproducible: Always

Steps to Reproduce:
1. access site thru home.cogeco.ca/~ve3ll
2. note page down action
3. add home.htm to address and jump there
4' note page down action
Actual Results:  
in frames -- no reaction to buttons
regular page -- no problem
((and noting no arrow or home end while
typing this error message too blahhh!))

Expected Results:  
page down should always move thru document if
there is more to move thru !!!
This is some sort of focus issue -- if I open view-source and then close it
scrolling starts to work...

This needs a minimal testcase.
Keywords: qawanted
(Reporter)

Comment 2

15 years ago
it does appear to be a nested frameset -- focus issue!!
when driving frameset is simple one framer, the pagedown
does not work until focus is on doc... it then works ok!
however with the nested frameset as on home.cogeco.ca/~ve3ll
getting focus on the document is trickier...  placing cursor
in doc zone and clicking does not work .... 

<<simple frameset which works ok after focus follows>>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">
<html><head><title>JR's Education Page</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset>
<frame src="home.htm" name="frmMain" id="frmMain" frameborder="0"
       scrolling="auto" marginwidth="0" marginheight="0">
</frameset>
<noframes><p>This page is designed for browsers using frames. For those
without frames, click on <a href="home.htm">No Frames Version</a></p>
</noframes></html>
(Reporter)

Comment 3

15 years ago
definitely a focus issue that happens with nested framesets!!
the original site home.cogeco.ca/~ve3ll  will not pagedown even
with focus ....  but using a menu item that opens a dialog 
such as file / save as ...  then cancel out , focus and down page
works ok.  do a refresh and back to no downpage 
use another menu dialog and focus ... hey it is repeatable
is there a way to get focus to work on nested framesets...
other browsers are not having any problems... in fact msie is
prefocused and ready to go from page load. 

Comment 4

13 years ago
john: it looks like the original (frame set) version is inaccessible.  it just
redirects to home.htm.  Do you have the original index.html that exhibitted this
bug?
(Reporter)

Comment 5

13 years ago
I am sorry but I removed frames from my site ealier in 2005.
Like many other designers have found, most browsers screw up
this construct somehow and there are better ways to do most
things now that CSS positioning has gained better support.
Also many sites with frames were so ugly with several sets
of scrollbars.  My need was to keep the menu onscreen after
scrolling is now solved with Javascript. 
i guess this can be marked as unconfirmed or unfounded if no
one else sees need for repair. 
personnally i agree with w3.org who are trying to make frames
obsolete .... 

Comment 6

13 years ago
ok, thanks

resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.