Necko crashes M12 after a few minutes w/ animated GIF

VERIFIED DUPLICATE of bug 18110

Status

()

P3
critical
VERIFIED DUPLICATE of bug 18110
19 years ago
19 years ago

People

(Reporter: niles, Assigned: gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Well, I'm not sure why but M12 on my RedHat 6.1
system only lasts about 3 mins before crashing
if the page has an animated GIF on it.
(usually a banner advert.)
I do nothing but launch the mozilla, go to
any page with animation and wait...


It crashes with:

Program received signal SIGSEGV, Segmentation fault.
0x402d0269 in main_arena () from /lib/libc.so.6
(gdb) where
#0  0x402d0269 in main_arena () from /lib/libc.so.6
#1  0x400f79cf in nsCOMPtr_base::assign_with_AddRef ()
   from /home/niles/package/libxpcom.so
#2  0x410c7c5d in NSGetModule ()
   from /home/niles/package/components/libnecko_http.so
#3  0x410c7cf5 in NSGetModule ()
   from /home/niles/package/components/libnecko_http.so
#4  0x410c4055 in NSGetModule ()
   from /home/niles/package/components/libnecko_http.so
#5  0x410c41f0 in NSGetModule ()
   from /home/niles/package/components/libnecko_http.so
#6  0x4049c861 in NSGetModule ()
   from /home/niles/package/components/libnecko.so
#7  0x4049cde5 in NSGetModule ()
   from /home/niles/package/components/libnecko.so
#8  0x4049c8fc in NSGetModule ()
   from /home/niles/package/components/libnecko.so
#9  0x40112c6d in PL_DestroyEvent () from /home/niles/package/libplds3.so
#10 0x40112c46 in PL_HandleEvent () from /home/niles/package/libplds3.so
#11 0x40112b86 in PL_ProcessPendingEvents ()
   from /home/niles/package/libplds3.so
#12 0x400f231a in nsEventQueueImpl::ProcessPendingEvents ()
   from /home/niles/package/libxpcom.so
#13 0x4050b1e7 in nsAppShell::SetDispatchListener ()
   from /home/niles/package/libwidget_gtk.so
#14 0x4050adad in _init () from /home/niles/package/libwidget_gtk.so
#15 0x406a352a in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#16 0x406a4be6 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#17 0x406a51a1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#18 0x406a5341 in g_main_run () from /usr/lib/libglib-1.2.so.0
#19 0x405cc209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#20 0x4050b635 in nsAppShell::Run () from /home/niles/package/libwidget_gtk.so
#21 0x4045c532 in nsAppShellService::Run ()
   from /home/niles/package/libnsappshell.so
#22 0x804a5d5 in JS_PushArguments ()
#23 0x804a859 in JS_PushArguments ()
#24 0x401fb1eb in __libc_start_main (main=0x804a684 <JS_PushArguments+4928>,
    argc=1, argv=0xbffffb34, init=0x80490b4 <_init>, fini=0x804bbf0 <_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffb2c)
    at ../sysdeps/generic/libc-start.c:90
(Reporter)

Comment 1

19 years ago
I should have mentioned I have a Dual-Processor SMP machine
so this could be related to Bug #18110.

Also, since it involved images it could be related to
Bug #21036.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 18110 ***

Comment 3

19 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.