MBNA Net Access site say I "must upgrade to Netscape 6.2 or higher"

VERIFIED FIXED

Status

VERIFIED FIXED
15 years ago
4 years ago

People

(Reporter: mozilla.org, Unassigned)

Tracking

Details

(Whiteboard: 1-800-421-2110, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031206
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031206

Going into the "new" MBNA Net Access website to pay my credit card bill now
shows the following message when accessing the PAY MY ACCOUNT section:
*** We have detected that your browser is an older version of Netscape. You must
upgrade to Netscape Navigator 6.2 or later.***

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
report that came in over webmaster alias

Hello
 
First, let me say I loved Mozilla until finding Firebird. Who doesn't use it?
 
Both browsers were more than happy to assist in paying my MBNA credit card bill
online. In November, http://www.mbna.com/index_main.html changed to a new,
clunkier(!?) format, yet payments were possible, albeit after clicking through a
maze of pages.
 
For December, the first attempt to pay was halted by a please-update-browser
request. Sure enough, I didn't have the newest version of Firebird. A few
minutes later: same message. Mozilla 1.5 (and IE5.5) got the same. A machine
with Netscape 7.something was able to get through though. Both machines run Win
2000 Pro in Japanese.

Comment 2

15 years ago
I can confirm this. I was able to pay my bill last month but not this month.

I called the MBNA customer service number and finally talked someone into
connecting me with tech support.  I got a tech who called himself Steven and
told me Mozilla and Safari were no longer supported since the bank's most recent
"security" upgrades, but I could set the UA string to spoof MSIE or Netscape 7.

When I asked him what features Mozilla lacked to make it incompatible with their
new security features, he said they use 128 bit encryption and Mozilla only
supports 56 bit (obviously false).  When I asked him if their site used 128 bits
last month when I successfully paid my bill, he said yes.  So when I returned to
the question what they changed since last month that Mozilla's supposedly
incompatible with, he said, well, now all their software insists on the
"stronger encryption."  When I asked him how he could say with a straight face
it's about cryptographic security, when the advice he's giving me is to change
my UA string and not change my crypto capability at all, he said (with a
straight face), "well, it's keeping YOU out, isn't it?"

Classic.  Obviously they have a stupid browser detect algorithm and they've all
been coached to call it "enhanced security" when customers call who can't pay
their bills, no matter how much they have to contradict themselves to do it.  :/

Comment 3

15 years ago
*** Bug 229725 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
I talked to them last night.  They said it was because they just redid their
online website and are working on the problem.

The only "Netscape" they recognize at the moment is 6.2 or greater, so you'd
have to UA spoof Netscape.  As I said, they have been notified.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
*** Bug 233572 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 234854 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 231406 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 231487 has been marked as a duplicate of this bug. ***
I just spent some time on the phone with the customer service people
(1-800-421-2110).  The woman I talked to said that I was the fifth person she'd
had calling about this issue so far this month (this is just her), and that they
are making a list of account numbers of people who call and once they have
enough will bring it up with someone who can do something about it.

So anything that can be done to get more people to contact them about the
problem is good.  If you haven't called them yet, please do.
Whiteboard: 1-800-421-2110

Comment 10

15 years ago
(In reply to comment #9)
Per your comment, I gave them a call to add my name to the list.. I was first
transferred to their Tech Support line (800-653-2465) and then to web support. 
Finally, the man I spoke to knows about it and said that it's currently being
worked on and should be fixed by the next billing cycle.  He also put my account
num. on the list of people requesting it to be fixed.

Comment 11

15 years ago
I'm calling right now.  I've had to use user agent spoofing since switching to
Firefox.

Comment 12

15 years ago
The account manager who I spoke with said that MBNA is waiting on Mozilla to get
back to them in order to fix the problem.  (Yes, *I* understand that its their
browser detection choking on the UA string and nothing that Mozilla needs to do
anything about, but) hopefully someone from Mozilla can go ahead and contact
them and help them.  She asked if I knew the workaround for it, and I said I did
(so at least her answer wasn't "sorry I can't help you", but rather she offered
a solution).  I also let her know that though the UA switcher works, I don't
want to have to suggest that my whole family install it -- that's just silly.

The call ended on a positive note with me saying "I'm happy with being on the
list of customers requesting that this be fixed".  Hopefully that "honey" (as
opposed to vinegar) I gave will help.
Hm... When I talked to them I told them that I'm a Mozilla developer in addition
to being a customer, and they didn't mention any of this "waiting on Mozilla"
bullshit...  <sigh>.

Comment 14

15 years ago
My understanding is this is the fault of their new online payment system,
provided by CheckFree.
Perhaps complaints to MBNA are the wrong way to go about it.
If CheckFree is trying to become a generic online payment company, they are not
going to be able to get away with just supporting 95% of the browsers out there.
Can anyone find some good contact information for these folks?  I tried e-mail
with no response.

Comment 15

15 years ago
*** Bug 233700 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Still not fixed. Doesn't work with Mac OS X either.  Called and added my name to
the list.

Comment 17

15 years ago
I've been using this (I think its the latest Netscape String) in the UA switcher:

Netscape 7.1 (Windows XP)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Netscape/7.1 (ax)


Its terrible that they haven't fixed it yet, but the workaround does work.

Comment 18

15 years ago
I'll put this here for everyone, even though it was John who emailed me about it...

User Agent Switcher for Mozilla and Firefox
http://www.chrispederick.com/work/firefox/useragentswitcher/

Its pretty self-explanatory and simple to use.  It comes with 3 built in
alternative UAs but I think in this case the one for Netscape is most
appropriate (see my previous comment).
That workaround is in fact the official company policy in the interim.  If
people use it, then MBNA wins -- clearly they don't need to change anything....

Comment 20

15 years ago
I don't know enough about UA strings but couldn't we all agree on using a
modified one which would put something to the effect of 
"Your website is broken, please fix it, more info at
http://bugzilla.mozilla.org/show_bug.cgi?id=227992"
in the UA which would show up in their logs?  I'm sure my suggestion is wrong
because of commas or because its too long, but I'm sure you get the point.


BTW, has "someone from Mozilla"" contacted them yet?

Comment 21

15 years ago
If people decide to try to get attention in server logs (however unlikely it is that it will be noticed), please remember to change the UA back as soon as you're done with the MBNA website...
Has anyone else tried e-mailing CheckFree yet?
What about calling?

Updated

15 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 22

15 years ago
(In reply to comment #21)
> Has anyone else tried e-mailing CheckFree yet?
moreinfo@checkfree.com
Is this something each of us should do, or someone more "official" than just
plain ol' me?


also...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Netscape/7.1 (Firefox0.8 - You're website works fine in my browser, but you
sniffer is broken, please fix it)
...works as a UA for the site -- but I don't like the wording -- please help!!

http://www.mozilla.org/build/revised-user-agent-strings.html
...is where to learn about UAs.

http://www.tufts.edu/webcentral/useragent.php
...lets you see what you are sending to the server.

Comment 23

15 years ago
I forgot to add that the latest version of the UA switcher has an option to
reset your UA on browser close. 

Also, I am hoping that we can agree on the alternative string to use so they
server logs will see the *exact same* string over and over.  That's why I wanted
help with wording -- so it sounds good to all of us (or most of us, at least)

Comment 24

15 years ago
*** Bug 240995 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
In the spirit of Evangelism BugDay, I put in some time to get this solved.  The
IRC log should speak for itself...

[15:16] <zachariah> If this is too off topic, let me know and I'll leave it
alone, but I figure since its evangelism related I'd see if I could be the
squeeky wheel that get's the oil.
[15:16] <zachariah> I know that the focus today is on the top 100, but I want to
know how to get "someone from Mozilla" to contact MBNA (or CheckFree) about Bug
227992.  
[15:16] <zachariah> The account manager who I spoke with said that MBNA is
waiting on Mozilla to get back to them in order to fix the problem.
[15:16] <zachariah> I know it is lame that they should need to talk to you since
the problem with the site is simply their browser sniffing (Mozilla/Firefox *is*
Navigator 6.2 or later).
[15:17] <vt100> zachariah: do they want to see some mozilla.org mail address? ;)
[15:17] <zachariah> They want a call, as far as I can tell
[15:17] * vt100 can only do free calls from within fwd.com ;)
[15:17] <zachariah> they said they attempted to contact mozilla and were waiting
for a response
[15:18] <vt100> oh, it's 1-800
[15:19] <Asa> zachariah: that might be a question bc can answer. (the mbna
phonecall)
[15:21] <zachariah> is that right, bc -- is this something you can do? :)
[15:30] * bc_food is now known as bc
[15:30] * bc scrolls back
[15:34] <bc> zachariah:  you have any contact info/email from the person you
spoke with re mbna?
[15:39] <zachariah> bc: (there are lots of details here
http://bugzilla.mozilla.org/show_bug.cgi?id=227992 of course) -- I called their
customer service number 1-800-421-2110 -- apparently I didn't get the woman's
name who I spoke with
[15:40] <bc> they want an account number
[15:40] <zachariah> I was calling to add myself to the list of unhappy customers
and ended up with a little extra info (or excuses)
[15:40] <bc> without an account number, seems that 800 number won't let me past.
[15:41] <bc> zachariah:  if you could call them again and find someone who can
contact me at < bob_clary @ bclary.com >, I will try to help.
[15:41] <zachariah> Yes, I'll contact them
[15:41] <zachariah> in just a minute
[15:45] * zachariah calling mbna
[16:00] <zachariah> bc: Gaston from MBNA technical support will provide your
email address, and my explanation of the problem to his manager
[16:00] <bc> zachariah:  excellent. 
[16:02] <zachariah> if they don't contact you soon, will you let us know by
posting on http://bugzilla.mozilla.org/show_bug.cgi?id=227992 that you are still
waiting for them to contact?  Should I "log my call" today on that bug as well?
[16:02] <bc> zachariah:  yes, please do
[16:02] <zachariah> cool

Comment 26

15 years ago
Looks like MBNA/Checkfree have listened.  Went there tonight and made a payment
without any problem.

Comment 27

15 years ago
Confirm that it works with 1.7b. Thanks for everyone's hard work staying on them.

Comment 28

15 years ago
Confirmed that it works with Galeon as well.  (Just in case they were still
looking for something overly-specific.)

Comment 29

15 years ago
per comments, -> fixed. Thanks everyone. This wouldn't have been fixed without you.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Verified fixed (Firefox 20040415/Win2k).
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.