CSS generated content breaks form submission

RESOLVED DUPLICATE of bug 228020

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 228020
15 years ago
15 years ago

People

(Reporter: joey, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031120 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031120 Firebird/0.7

If you will view the demonstration URL, you'll see that I'm trying to use CSS to
generate labels that are NOT to be part of the semantic markup (hence the reason
I'm not using <label>). When I use the CSS "content:" property on an input,
Mozilla/Firebird will not pass the data I entered into the input.

I thought this might be somewhat related to 155957, but the breakage seems much
more fundamental.

Reproducible: Always

Steps to Reproduce:
1. Visit demo URL
2. Enter some data
3. Press submit
4. Look at your URL

Actual Results:  
The data values didn't get passed to the form action
(Reporter)

Comment 1

15 years ago
Got submit happy, I guess.

*** This bug has been marked as a duplicate of 228020 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.