CSS generated content breaks form submission

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: joey, Unassigned)

Tracking

({dataloss})

Trunk
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031120 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031120 Firebird/0.7

If you will view the demonstration URL, you'll see that I'm trying to use CSS to
generate labels that are NOT to be part of the semantic markup (hence the reason
I'm not using <label>). When I use the CSS "content:" property on an input,
Mozilla/Firebird will not pass the data I entered into the input.

I thought this might be somewhat related to 155957, but the breakage seems much
more fundamental.

Reproducible: Always

Steps to Reproduce:
1. Visit demo URL
2. Enter some data
3. Press submit
4. Look at your URL

Actual Results:  
The data values didn't get passed to the form action
(Reporter)

Comment 1

15 years ago
*** Bug 228019 has been marked as a duplicate of this bug. ***
Confirmed on WinXP SP1 trunk 2003120608.
Moving to All/All, Browser: HTML Form Submission
Agreed Critical, since it causes dataloss.
Assignee: blake → form-submission
Status: UNCONFIRMED → NEW
Component: General → HTML: Form Submission
Ever confirmed: true
Keywords: dataloss
OS: Linux → All
Product: Firebird → Browser
Hardware: PC → All
Version: unspecified → Trunk
> I thought this might be somewhat related to 155957,

Related like an identical twin, really... I'll be posting the patch in that bug.
Depends on: 155957
(Reporter)

Comment 4

15 years ago
All right, I apologize for the dup, then. The other seemed to focus on caret
placement, which appears to work fine for me...it's the acutal values that are
broken here.
Well, it's hard to know that they are really the same problem without looking at
the code.  ;)
Fixed for 1.6 by patch in bug 155957
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.