Status

SeaMonkey
General
--
enhancement
VERIFIED INVALID
14 years ago
13 years ago

People

(Reporter: Philipp Weissenbacher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

With PDF warning I mean that, if a link points to a PDF file the mousecursour
changes to e.g. an arrow with a small "PDF" tag. Thsi would inform the user if
he's clicking onto a link wich leads to a PDF file. The main advantage is that
the user knows when Mozilla opens a PDF file (prevents the user of waiting till
the PDF plug-in has started up).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
INVALID. We can't know that a link will return a PDF file until we attempt to 
retrieve the resource.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
I meant if the link points to a file wich ends with *.pdf.

Comment 3

14 years ago
That doesn't mean it's a PDF. We need to know the MIME type of the 
representation, and we only get that when we retrieve it.

Examples:

Is this a PDF?
http://www.opm.gov/forms/pdf_fill/of0612.pdf

No, it's HTML. (and although it says '404 not found', that's a lie - it's 
returning a valid HTML document and a '200 OK' status).

What about this?
http://econ-www.mit.edu/faculty/download_cv.php?prof_id=acemoglu

Not PDF? Nope, it is.

Comment 4

14 years ago
Another (better) example:
http://www.westernorthodox.com/Lux-Occidentalis

Which isn't even a dynamic page.

On the web, the names of URL's do not necessarily bear any relation to the 
content.
verified invalid

Mozilla must get the header for the file.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

14 years ago
So it's not possible?

Comment 7

14 years ago
No, because the type is determined by the content-type (inside the file), not by
the file-extension (in the link). 

It might be possible with the type attribute of the A-tag (like <a
href="http://www.westernorthodox.com/Lux-Occidentalis" type="application/pdf">),
see <http://www.w3.org/TR/html4/struct/links.html#h-12.2>. But even in this case
you have to accept that the actual content might be different than the
type-hint. And what if your cursor indicates that it's a PDF file, but it's
really a Word-document ? With possibly a macro-virus inside ? I can already
imagine the bug-report.

Note: it's still a good idea for an extension, though ...
(Reporter)

Comment 8

14 years ago
Ok. I just found a thing like this very useable.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.