Closed Bug 228061 Opened 19 years ago Closed 19 years ago

Downloads slow down after repeated use

Categories

(SeaMonkey :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 161783

People

(Reporter: lottajunx, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

I've been downloading things in the browser from images, .doc's, ppt's, and
pdf's.  I've been using it for a while.  Nowadays, when I want to download an
image, the browser pauses for about 10 seconds.  I created a new profile and I
don't experience this slowdown.  I've tried to clear the cache but this did
nothing.  I think it might be the download manager.  

Reproducible: Always

Steps to Reproduce:
1.  right click on an image.
2.  Select Save Image.
3.  Select a location to save.
This is when I experience the pause.
4.  Open download manager.
5.  select all the items in the list (I have about 1000+ items).
6.  Click "Remove from List" Button.
Completely lock out.  I have to go to task manager to end the program.

Actual Results:  
See above.

Expected Results:  
After step 3, I should not have experienced a pause.
After step 6, the download manager and mozilla should not have frozen.  I should
be able to select every item listed in the download manager and click remove
list.  As is is, I have to highlight no more than 10 items at a time.
workaround: 
Close Mozilla, delete downloads.rdf in your profile. An empty file will be
recreated at next start of Mozilla.

Bug 159107 page saving takes too much time ('marooned' entries in downloads.rdf)
Bug 161783 Need a more scaleable implementation for download data storage

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.