Java LoadPlugin fails with gcc32 plugin

RESOLVED DUPLICATE of bug 227867

Status

()

--
major
RESOLVED DUPLICATE of bug 227867
15 years ago
5 years ago

People

(Reporter: t.muhlhofer, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031209
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031209

When viewing page above (or any page containing a java applet), Mozilla asks me
if I want to download the plugin. The Java plugin is also not displayed in
about:plugins.

I have j2re-1.4.1_03 installed and have my symlink to the gcc32 version of
libjavaplugin_oji.so. When starting Mozilla from a terminal, it gives the
follwing debug info:

LoadPlugin: failed to initialize shared library
/usr/java/j2re1.4.2_03/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
[/usr/java/j2re1.4.2_03/plugin/i386/ns610-gcc32/libjavaplugin_oji.so: undefined
symbol: _ZdlPv]

Also had this problem with the Mozilla 1.6b release, but not with 1.5.

Reproducible: Always

Steps to Reproduce:
1.Start Mozilla
2.Go to about:plugins or any page that has Java
3.

Actual Results:  
No evidence of the presence of a Java plugin.

Expected Results:  
executed the corresponding applets
Whiteboard: dupeme

Comment 1

15 years ago
It looks like 1.6b and the 1209 nightly were built using gcc 2.96 rather than
3.2. I havent' tested this, but as a workaround you could try switching to the
non-gcc32 version of the plugin which you'd find in ...plugin/i386/ns610-gcc32/.


*** This bug has been marked as a duplicate of 227867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Java plugin not loading → Java LoadPlugin fails with gcc32 plugin

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.