referrer is not generated for inline images

RESOLVED WORKSFORME

Status

()

Firefox
General
--
enhancement
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Can Burak Cilingir, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031109 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031109 Firebird/0.7+

Firebird does not send referrer info while fetching images from an html file.

following apache config become useless for detectiing the images included from
another server.
#SetEnvIfNoCase Referer "^http://server.com/" local_ref=1
#<FilesMatch ".(gif|jpg)">
#       Order Allow,Deny
#       Allow from env=local_ref
#</FilesMatch>


Reproducible: Always

Steps to Reproduce:
1. open any html file with images in it
2. check the server's log file if referrer is sent


Actual Results:  
i did not observed referrer is sent as the container htmls address

Expected Results:  
referrer should be sent as the container page's address

Comment 1

15 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031209
Firebird/0.7+

I tested by loading a page from a local web server (OmniHTTPd) at [my
hostname]:112 containing a reference to a non-existent GIF.

A) How are you loading the image?  <img src="..."> or something else?

B) Have you ever disabled referrers?  What does about:config say for
network.http.sendRefererHeader?

C) Does it work correctly with other browsers?

D) Does it with correctly with a newer nightly of Firebird?
(Reporter)

Comment 2

15 years ago
about:config says network.http.sendRefererHeader default integer 2 (i did not
changed this kind of thing)

i tested with ie6 and observed referrers were sent. actually: apache was able to
block requests made with ie, but could not able to block if requested by
firebird because referrers were not send. (look at the given apache config)

images are loaded with <img src=""> as usual.

did you observed the referrers were sent while getting _each_ image? 

Comment 3

15 years ago
> i tested with ie6 and observed referrers were sent. actually: apache was able 
> to block requests made with ie, but could not able to block if requested by
> firebird because referrers were not send. (look at the given apache config)

I'm not familiar enough with Apache to tell whether your config is correct.  Do
you have the ability to view Apache's access.log to see the exact referer each
browser sends for each image request?

> did you observed the referrers were sent while getting _each_ image? 

My test page only had one image.  How many images do you think it should have?

Did you test with a newer nightly?

Comment 4

14 years ago
worksforme per comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.