Camino renders the display badly above a certain vertical resolution

RESOLVED DUPLICATE of bug 159552

Status

defect
RESOLVED DUPLICATE of bug 159552
16 years ago
16 years ago

People

(Reporter: Stuart.Lamble, Assigned: mikepinkerton)

Tracking

({qawanted})

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031210 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031210 Camino/0.7+

If I open a web page that is fairly long, and Camino's window is sized above a
certain resolution (the exact resolution is uncertain), scrolling down in the
window renders very badly, with major gaps and glitches.

Reproducible: Always

Steps to Reproduce:
1. Open a browser window. Full screen 1280x1024 is sufficient (by some margin).
2. Open a web page that is sufficiently long to scroll.
3. Scroll down.

Actual Results:  
Display mis-rendered badly.

Expected Results:  
Render it properly, as with a smaller browser window.

Screen shots coming _very_ shortly. (just need to get them in a good format and
to a reasonable size).
(Reporter)

Comment 1

16 years ago
Rather than tie up half a meg of database space with attachments, sample cases
of the misrendering (along with a good render with a slightly smaller window)
have been put on a web. See http://carousel.its.monash.edu.au/~lamble/moz_bug/
for the JPEG images. Those images will stay put until this bug is closed for
whatever reason (unless Monash removes access from the greater Internet to that
system, in which case I'll add a comment on where the moved images can be found).
(Reporter)

Comment 2

16 years ago
Just checked. Full screen 1280x854 (my laptop's screen resolution... mmm, 15" Al
PowerBook :) is _NOT_ enough to trigger the bug.

Oh, and with regards to the .jpg/.gif/.png files in that directory mentioned in
comment 1: if the basename's the same, they're essentially the same content. No
need to look at all of them. The .jpg's have been severely compressed, so there
will be a lot of compression artifacts, but the misrendering I'm talking about
should be obvious nonetheless.

Comment 3

16 years ago
WFM Camino 2003121003
Blue and White stock Rage128
This is most likely a dup of another "I get artifacts when I scroll" bug

Can anyone one with the same set up test this? Or can anyone else at least dup it?

QA needed to find the dup.
Keywords: qawanted
this is probably a dupe of the "problems if i make the window larger than main
screen" bug that is a limitation in apple's nsquickdrawview.
(Reporter)

Comment 5

16 years ago
Regarding comment 4: I'm willing to put down my life savings ($AU5000, not
counting stock-based investments) that that's the problem. Certainly, that
description matches the situation pretty much identical: I'm using a 15"
PowerBook hooked up to a 17" LCD (1280x854 and 1280x1024, respectively), and the
problem's manifesting on the 17" LCD.

That being the case, I'm happy to have this closed as a dupe of the other bug
pinkerton mentioned. Sorry -- I did try to find a similar bug. Honest! (Maybe a
mention in the release notes about this?)

Just reviewed bug 159552. It's a dupe. Marking as such.

*** This bug has been marked as a duplicate of 159552 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.