If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Broken context menu 'edit' on HTML files

RESOLVED DUPLICATE of bug 216432

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 216432
14 years ago
14 years ago

People

(Reporter: Jess Collicott, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208 Firebird/0.7+

I'm not sure if this is Firebird or not, but I didn't notice it until I made
Firebird my system's (w2k) default browser.

If I right-click on an .html file, I see a context menu option of 'edit'. When I
click 'edit', I receive a XUL styled popup (it's not a native system alert
anyway), that says:

"The file /content/editor.xul cannot be found. Please check the location and try
again."

Personally, I don't want the context menu option there (and I can go into the
registry I guess), but thought I would file since the application link is broken.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
I should have mentioned I have Mozilla 1.6b on my system as well. However the
style of the warning icon reminds me of JavaScript console style in Firebird,
not Mozilla Suite.

Comment 2

14 years ago
Happens to me also.
Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.6b) Gecko/20031211 Firebird/0.7+

I don't have Mozilla on my system.
a) you shouldn't have "edit" as a context menu item
b) its trying to launch Composer

go to Internet Options, set IE as the default browser, and Notepad as the
default text editor.  Install Firebird (current nightly) and create a new
profile.  Test like that for this context menu.  If it isn't there, set as
default again, and try again.

This could be a legacy from something older, before a few FB vs. Editor bugs
were fixed.
QA Contact: mpconnor

Comment 4

14 years ago
Dup of bug 176096, which was fixed a while ago.
(Reporter)

Comment 5

14 years ago
I just did a test based on comment #3:

1) I set IE as the default browser and Notepad as the default text editor.
1b) I noticed the context menus had changed back to pre-Firebird menus.
2) Downloaded a nightly from 12/8 (before the new bookmark UI was checked in).
3) Installed Firebird with the installer, performing a 'safe upgrade'.
4) Before I ran Firebird after install, I created a new profile.
5) Ran Firebird, selecting the new profile.
6) Set Firebird as the default browser, through its own options and through the
W2K applet in the Control Panel.

I again see the 'edit' option in the context menu on .html files, and when I
click on it receive the same error.

When I install Firebird, I am clicking 'custom' and checking the development
tools - however there is no mention of the Editor.

Comment 6

14 years ago
*** Bug 228349 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 228563 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I think this has been fixed by bug 216432. Can anyone confirm?

Comment 9

14 years ago

*** This bug has been marked as a duplicate of 216432 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.