tabbing between form elements is broken

VERIFIED DUPLICATE of bug 22540

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 22540
20 years ago
4 months ago

People

(Reporter: gwalla, Assigned: karnaze)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
In the M12 for Win32 (no fullcircle), running on Windows 95, I loaded Hotmail's
page (http://go.msn.com/0/1/ -- their main page does not load, a separate bug)
and attempted to log in.

After typing my login name in the first text field, I hit tab. Focus seemed to
go to the next element (a drop-down list with one option), but a second tab
failed to shift the focus to the third element (a password field), and when
typing my input was appended to the contents of the first field.

From playing around with the form, it looks like there are three problems:

1) tabbing from one form element to another makes focus seem to shift,
graphically (first element looks unfocused, next element looks focused), but
keyboard focus is not shifted. Input still goes to the old element.

2) after tabbing to the second element, a second tab does not shift the focus at
all, graphically or actually: keyboard focus remains on the first element, and
the graphical signs of focus at the second.

3) Clicking in the first field when the second has "pseudo-focus" seemingly does
nothing. The cursor does not appear, and typing continues to add text where the
cursor was before the tab.

I'm guessing that these problems have the same source: tabbing causes the focus
to shift for the graphical widgets, but the focus does not move as far as the
rest of the program is concerned. Since the actual focus has not changed,
tabbing a second time simply tries to shift the graphical focus to the second
element again, with no perceptible change as the second element's widget already
"thinks" it has focus. This schizoid behavior probably also prevents the first
field from receiving mouse events.
Reporter

Updated

20 years ago
Component: Editor → HTML Form Controls
Product: Architecture → Browser
Version: 5.0 → other
Reporter

Updated

20 years ago
Assignee: nobody → karnaze
QA Contact: nobody
Reporter

Comment 1

20 years ago
Oops, submitted this as a bug in the wrong component. Should be Browser, HTML
Form Controls
Reporter

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Reporter

Comment 2

20 years ago
*** This bug has been marked as a duplicate of 22540 ***

Comment 3

20 years ago
verified dupe of bug 22540 Tabbing between input fields doesn't work
Status: RESOLVED → VERIFIED

Comment 4

4 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/32b792a2a7a4
No bug - Cherry-pick changes from Servo PR #22825. r=npotb
You need to log in before you can comment on or make changes to this bug.