Closed Bug 228275 Opened 21 years ago Closed 21 years ago

Can't use Enter key to navigate to <AREA> links

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 214373

People

(Reporter: alunw, Assigned: aaronlev)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

The Tab key can be used to navigate around all the <A> and <AREA> links on a web
page.
The Enter key can be used to navigate to <A> links, but not to <AREA> ones.

Reproducible: Always

Steps to Reproduce:
1. Find any web page using <AREA> tags, e.g. one above
2. Use Tab key to navigate to a AREA link
3. Press Enter - nothing happens

Actual Results:  
Nothing

Expected Results:  
Navigate to href of AREA tag. IE does this.
(b.t.w. Opera is even worse in this area)
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031205
taking back WFM. 

Confirming with same browser
CONFIRMING: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031212

(Since this bug is apparently here since 1.5, I'm almost sure this is a duplicate)
found it...

*** This bug has been marked as a duplicate of 214373 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.