Install folder picker should default to the default installation directory

RESOLVED DUPLICATE of bug 241282

Status

()

RESOLVED DUPLICATE of bug 241282
15 years ago
13 years ago

People

(Reporter: Bugzilla-alanjstrBugs, Assigned: mscott)

Tracking

unspecified
Firefox0.9
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
When using the installer, it asks if you want to use the default directory of
C:\Program Files\Mozilla Firebird.  If you choose a custom location, it takes
you to My Computer in the directory browser.  I think it should start off in
C:\Program Files with a folder name of Mozilla Firebird in the folder name box.
(Reporter)

Updated

15 years ago
Summary: Install folder should default to Program Files\Mozilla Firebird → Install folder picker should default to Program Files\Mozilla Firebird

Updated

15 years ago
Summary: Install folder picker should default to Program Files\Mozilla Firebird → Install folder picker should default to the default installation directory
(Reporter)

Comment 1

15 years ago
It would help if the screen that had the Browse button had an editable text box,
too.  Then I wouldn't need to use the picker in the first place.  Just make sure
that if someone puts the path in via a textbox that you create a new folder if
necessary.
(Reporter)

Comment 2

15 years ago
Ok, there is an editable box, but I think it should be on the previous screen
like I put in Comment 2.  But that's a different bug that I'll file some other day.

Comment 3

15 years ago
alanjstr: the box is not editable on WinXP, although it would be nice.   
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040120
Firebird/0.7+)
mscott was going to fix this 
Assignee: bugs → mscott
(Assignee)

Comment 5

15 years ago
I checked in a fix for this under another bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox0.9

Comment 6

15 years ago
This doesn't appear to be working. I've just tried a custom install of the
latest Firefox branch nightly 2004071509 on Windows XP and it did not default to
Program Files. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

14 years ago
The current default path (last installation folder) is good for many users who
prefer to replace the old version with the new one. I don't see any reason to
change that.

The "Make New Folder" button, on the other hand, is mostly used by testers who
wish to keep several versions of Firefox (e.g. to track regressions), or by
cautious users who want an easy way to revert a bad install. In both cases, the
logical default path should be the *parent folder* of last install (in my case,
that would be C:\Program Files\mozilla.org\ and not C:\Program
Files\mozilla.org\Firefox 0.10.1\)

In short, the current default does make sense, but the Make New Folder creates
the folder in the wrong path and should be changed.

Prog.

Comment 8

14 years ago
I just ran the RC2 install (clean, but with clean RC1 profile) after having
trouble with the Software Update feature. When I chose "Custom Install" to move
the install from "C:\Program Files\Mozilla Firefox" to "D:\Program Files\Mozilla
Firefox" when I clicked browse it chose some strange folder deep inside my temp
directory. I was able to browse to the new location and "Make new folder" and
things went fine but I was confused for a second with the installer's choice for
the starting location.

Comment 9

14 years ago
Firefox 1.0 still has this issue in Windows 2000. All I want to do is change
from C:\Program Files\Mozilla Firefox to D:\Program Files\Mozilla Firefox

Here are my suggestions for when the Browse button is clicked:

- It should default to C:\Program Files\Mozilla Firefox instead of some
temporary folder
- The full path should be displayed and editable, not just the current folder name.
- When moving through folders, the "Mozilla Firefox" should be appended, so 
browsing to the folder D:\Program Files it will actually display D:\Program
Files\Mozilla Firefox in the editable path text box mentioned above.
- In the event that a new folder is created, the above should apply, so if a
"Web Browsers" folder is created in D:\Program Files, the actual path displayed
should be D:\Program Files\Web Browsers\Mozilla Firefox
- The "Mozilla Firefox" that is appended can always be removed through the
editable path input

Having the "Mozilla Firefox" move around as we move around through the folder
structure is usefull. Just imagine installing to C:\Windows

Comment 10

14 years ago
Checking on the status of this. This continues to remain a problem for me under
both Windows 2000 and Windows XP SP2 all the way through Firefox 1.0.2.

Comment 11

13 years ago
This bug seems to have existed in the Firefox and Thunderbird Installer since
its original introduction, up to and including Deer Park Alpha 2 (Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+).

Is there any chance of a fix before Firefox 1.1?

Comment 12

13 years ago
Hooray! Just installed Thunderbird 1.1a2, and the folder picker defaulted to
c:\Program Files\ as expected. Does this mean that this bug has also been fixed
in the latest Firefox nightly builds?

Updated

13 years ago
QA Contact: bugzilla → installer
Fixed (as much as it can be, being a native dialog) in bug 241282.

*** This bug has been marked as a duplicate of 241282 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.