If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] No way to restart a download after it has been canceled

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
enhancement
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Ignacy Niemczycki, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; pl-pl) AppleWebKit/103u (KHTML, like Gecko) Safari/100.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031201

I thing that there should be a button to restart a canceled download. The easiest way would be to 
start the canceled download just from beginning. First the old unfinished file would have to be 
deleted(I was wondering if this is not another bug: that file is not deleted after the download is 
canceled?, please help) and the the file would be re-downloaded using all the data that is already in 
download 
manager, that is: file location on web and the folder the file should be saved on local disk. This RFE 
is correlated with:
bug 191094 - add "add file" button to dwl manager
bug 131871
bug 131780 - dwl mngr ought to have pause/resume buttons
bug 18004 - general issues with downloads
Nevertheless, this RFE asks ONLY for simple restart button, not for ability to pause/resume 
downloads between sessions. I feel that this way it is much much easier to implement. Later, 
the developers could expand the functionality and add pause/resume buttons to dwl mngr as 
requested by bug 131780 and bug 18004. Probably this function is not also present on other 
platforms, but I don't have access to pcs.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
*** Bug 254273 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

12 years ago
We don't know what fixed this worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.