Cannot backup certificate

RESOLVED DUPLICATE of bug 217305

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 217305
14 years ago
11 years ago

People

(Reporter: Christoffer Sørensen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I have installed a SSL certificate from a vendor in Denmark (TDC). When I try to
backup the certificate, I am allowed to choose a filename and a password, but
Mozilla Firebird throws an error: "Failed to create the PKCS #12 backup file for
unknown reasons".

Other than not being able to backup my certificate, this error should probably
be explained better.

Reproducible: Always

Steps to Reproduce:
0. Install certificate.
1. Go to Tools -> Options -> Advanced -> Manage Certificates
2. Select the certificate.
3. Click backup
4. Choose filename and password. The error appears

Actual Results:  
An error:

"Failed to create the PKCS #12 backup file for unknown reasons".

Expected Results:  
Backup the certificate. If this is not possible, please give a better
description of the problem.
(Reporter)

Comment 1

14 years ago
See bug http://bugzilla.mozilla.org/show_bug.cgi?id=197009

Maybe this is a duplicate
I'm also suffering from this very same problem, I'm using mozilla 1.6-1 from
Debian, but I have been able to reproduce this also in mozilla-firefox 0.8, both
under Debian GNU/Linux unstable.

My certificate comes from Spain's government certifier (www.cert.fnmt.es), and
it has an ñ in the CN so it really could be the bug with the encoding, how could
I test if this is really that bug?

I've tested having a password and without a password in the software security
device just in case it made any sense.

I'd be happy to compile whatever is needed to test if this has been fixed in
development versions of mozilla or mozilla-firefox.

Thanks in advance!
I've just downloaded and installed
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218
which does recognize well the ñ and the other characters in my certificate,
however it still does give the same error when trying to backup the certificate,
so it seems that in this version bug #197009 is solved, but this problem still
remains.

If you need any more info about this just tell me.

Regards!

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 217305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.