Fbird/2 v0.7 crashes with SYS3178 divide-by-zero exception when accessing URL.

RESOLVED DUPLICATE of bug 237183

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 237183
15 years ago
15 years ago

People

(Reporter: Austy Garhi, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.5) Gecko/20031015 Firebird/0.7
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.5) Gecko/20031015 Firebird/0.7

System issues SYS3178 error, and makes reference to GKLAYOUT.DLL

Reproducible: Always

Steps to Reproduce:
1. Start Fbird/2 v0.7
2. Direct browser to access http://prefbar.mozdev.org/
3. Watch it crash.

Actual Results:  
Brwoser crashes, error box pops up with the message:
12-13-2003  01:35:14  SYS3178  PID 0038  TID 0001  Slot 0069
K:\USOF\MOZILLAFIREBIRD\MOZILLAFIREBIRD.EXE
c0000095
1dac5b32
EAX=3f800000  EBX=00000000  ECX=00000000  EDX=00a66f4c
ESI=00a66f08  EDI=0092b4c0
DS=0053  DSACC=d0f3  DSLIM=1fffffff
ES=0053  ESACC=d0f3  ESLIM=1fffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1dac5b32  CSACC=d0df  CSLIM=1fffffff
SS:ESP=0053:0011edf8  SSACC=d0f3  SSLIM=1fffffff
EBP=0011eefc  FLG=00002212

GKLAYOUT.DLL 0001:002d5b32

Expected Results:  
What browsers are supposed to do: display the contents the URL sends to browser.

Comment 1

15 years ago
WFM, with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031221
Firebird/0.7+

and also with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031220 Firebird/0.7+

Comment 2

15 years ago
The final solution to the divide by zero problems is in bug 237183

*** This bug has been marked as a duplicate of 237183 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.