Feature Request: Option to move "send message" progress to status bar

RESOLVED DUPLICATE of bug 440794

Status

enhancement
RESOLVED DUPLICATE of bug 440794
16 years ago
11 years ago

People

(Reporter: bernzilla+bugs, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4.1) Gecko/20031008
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4.1) Gecko/20031008

Those of us who have been using Outlook Express for a long time are used to
composing a message, hitting Send, and then having the message compose window
disappear immediately while the message is sent "in the background," so to speak.

In Thunderbird, when you click Send, the message stays up and a new "Sending
Message" dialog comes up that sits there until the message has been sent off, at
which time it disappears and the message compose window does the same.

This seems to slow down the process of reading and replying to emails, whereas
in Outlook Express you can immediately begin replying to another message while
your previous reply is being sent in the background (via the Outbox).

I'd like to submit a feature request for users to be able to have the option to
have their message sending status shown in the status bar (like in OE) rather
than via the dialog box that currently shows up in Thunderbird.  Furthermore,
the message compose window would go away immediately after Send was hit.

Reproducible: Always

Steps to Reproduce:
1.  Compose an email.
2.  Hit Send.
3.  Wait while the sending message dialog appears and goes through the sending
process.
4.  Message compose window then finally disappears.

Actual Results:  
Sending message dialog and message compose window take too long to get out of
the way so you can move on to your next reply (or whatever you may want to do next).

Expected Results:  
Message compose dialog should disappear immediately and message sending status
should be shown in the status bar (at least as a user preference).

Updated

15 years ago
Blocks: 223381

Comment 1

14 years ago
This is an ancient Bug now, but still valid.
Users migrating from Outlook Express (and probably other email apps as well) will no doubt be as annoyed as I was that the message compose window does not 'close' by itself when the Send button is clicked.

In a recent discussion about this issue, it came up that an extension called 'SendTools' includes (among other things) a function whereby upon hitting 'Send', the message compose window is closed, the message is moved into the Unread folder and the send takes place immediately. This is the exact behaviour I expected to see from TB in the first place!

SendTools is available at https://addons.mozilla.org/extensions/moreinfo.php?id=761&application=thunderbird
- though it has not been updated for TB1.5, it does install if the 'maxversion' is changed. I think there may be some issues with the extension itself, but from having tested it this morning on TB1.5RC2, the issue at hand here in this Bug is taken care of beautifully.
(note: though the send progress dialog (setting: user_pref("mailnews.show_send_progress" ) seems to be disabled even when the flag is set to 'true'.) --- which I have no problem with (as its shown on the statusbar), though there is no way to cancel a message-send already in progress unless you switch to 'offline' mode .

Perhaps if this something similar to what the extension is implemented, the statusbar send-progress meter could be clickable- a small box could pop up from it with a 'Cancel send' option?

Comment 2

13 years ago
*** Bug 286075 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
See also bug 218557 for turning it off by default (which I would prefer to it becoming a visible pref).  Btw, bug has instructions for turning it off using a hidden pref in about:config.
QA Contact: message-compose

Comment 4

11 years ago
I resisted the urge to request blocking TB3. :-)

I would however really like to see this in TB3, as it hinders workflow.
Flags: wanted-thunderbird3?

Updated

11 years ago
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440794
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.