Text not wrapped in alert and confirm dialogs in Javascript

RESOLVED DUPLICATE of bug 40508

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 40508
15 years ago
15 years ago

People

(Reporter: Craig Carey, Unassigned)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.74 [en] (Win95; U)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.5) Gecko/20030916

Text is not wrapping inside of the alert() and confirm() dialog windows.

Reproducible: Always

Steps to Reproduce:
1. Type in the Javascript URL. That same problem appeared in Javascript code.

Actual Results:  
The text is truncated on the right hand side.

Expected Results:  
The text wraps around inside of the box.

Please get the dialog window to correctly handle that case of there being so 
much text that the display screen is not large enough for the dialog window. 
Ideally Mozilla would not shift all buttons that close the alert/confirm dialog 
windows off the screen.

Two of my search webpages, display the cookie and the search query URL, in a 
confirm or alert dialog window. A MEDLINE search page can show the bug 
described: http://www.ijs.co.nz/med/medline.htm

Comment 1

15 years ago
This looks like a dupe of bug 40508

Updated

15 years ago
Assignee: general → general
Component: JavaScript Engine → DOM: Level 0
QA Contact: pschwartau → ian

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 40508 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.