Crashes on shockwave plugin at www.swatch.com

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
P3
critical
VERIFIED FIXED
19 years ago
8 years ago

People

(Reporter: John Morrison, Assigned: drapeau)

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
This bug is split out from bug #21711. While bug #21711 is also for a crash
on http://www.swatch.com/ I'm not clear that that report is mixing unrelated
problems (MS C Runtime DLL version, and Linux libjpeg loading) with a
particular plugin crash that occurs on www.swatch.com.

Overview:
  1999123008 Win95 crashes at http://www.swatch.com/ (likely on a
  shockwave plugin)

Steps to Reproduce:
 1) Simply load http://www.swatch.com/ or load the simplified attachment that
    isolates the HTML that causes the crash (to follow).

Expected Results: Page should load in all its javascript and Shockwave
  multimedia glory

Actual Results: on Win95 I get "MOZILLA caused an invalid page fault in module
  <unknown> at 0000:00000013."

Platforms tested: 1999123008 Win95

Additional Information: Here is the last few messages in the console window.

   nsXULKeyListenerImpl::Init()
   WEBSHELL+ = 7
   Setting content window
   browser.startup.page = 1
   startpage = http://www.news.com/
   Document about:blank loaded successfully
   WEBSHELL+ = 8
   WEBSHELL+ = 9
   WEBSHELL+ = 10
   WEBSHELL+ = 11
   debug: edburns ns4xPlugin::CreatePlugin

   C:\Program Files\Netscape\Seamonkey>

Setting this to 'plugins' but cc: edburns@acm.org for the debug message
(although
this is just a vanilla "entered routine" debug message).
(Reporter)

Comment 1

19 years ago
Created attachment 3910 [details]
simplified HTML from www.swatch.com (will crash Mozilla 12/30)

Updated

19 years ago
Severity: normal → critical

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 2

19 years ago
I tried this with today's windows commercial build (2000010308) and do not see
any problem. The plugin loads perfectly and the browser does not crash. Marking
as such. Please reopen if you still see this problem. Thanks!
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

19 years ago
Hmm. I crash on 1999010308 and 1999010208 win95 the same way as before. So,
I guess I have to REOPEN.

Here's my info from about:plugins for Nav4.6 (which, as I understand
it, is where Mozilla gets the plugin).
------------------------------------------------------------------------
Shockwave Flash
File name:
      C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npswf32.dll
Shockwave Flash 3.0 r8
------------------------------------------------------------------------
Mime Type                      Description            Suffixes   Enabled
------------------------------------------------------------------------
application/futuresplash        FutureSplash Player    spl        Yes
application/x-shockwave-flash   Shockwave Flash        swf        Yes
(Reporter)

Updated

19 years ago
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

19 years ago
clearing resolution

Comment 5

19 years ago
My version of shockwave on Navigator 4.7 is "Shockwave Flash 4.0 r7". I assume
here that you meant 2000 instead of 1999 in the build id's.
(Reporter)

Comment 6

19 years ago
> I assume here that you meant 2000 instead of 1999 in the build id's.

Doh!

Comment 7

19 years ago
3jrgm@qlink.queensu.ca, I think I found out the reason for the crash. In the
source, 'SWLiveConnect' has been set to "true". Setting it to "false" does
not crash. Am attaching the modified test case. Let me know your result. Thanks!

Comment 8

19 years ago
Created attachment 4052 [details]
Attached modified test case
(Reporter)

Comment 9

19 years ago
Yes. With the modification to set 'SWLiveConnect="false"' I load the test
without crashing -- the canvas is painted black in the plugin region.
(However, the plugin does _not_ run. (This is with win95 2000010608).

Interestingly, if I edit the file after loading it, setting the
SWLiveConnect="true", and then reload the page, the browser does not crash
(presumably because some "init()" function is not called the second time
(on reloading).
(Reporter)

Comment 10

19 years ago
... err, correction: it does run. (I just hadn't waited long enough, and there
was no visible UI feedback of 'loading' for ~40sec, so I had moved to another
page the first couple of times I tried this.)

Updated

19 years ago
Target Milestone: M13

Updated

19 years ago
Assignee: av → drapeau
Status: REOPENED → NEW
Component: Plug-ins → OJI
QA Contact: shrir → paw
Target Milestone: M13

Comment 11

19 years ago
It seems to be crashing in Java plugin. Reassigning to the owner for having a
look.

Comment 12

19 years ago
Could it be a dup of 18741? Adding myself to the cc list.

Comment 13

19 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Comment 14

19 years ago
av: Can you please provide some more backing to your statement that "it seems 
to be crashing in the java plugin"?  How can it be crashing in the java plugin 
when this is a shockwave plugin page?

Comment 15

19 years ago
The attached test case works as of Feb-14-2000 build using the unreleased 
patched Java Plugin. Any build after M12 and before the patch Java Plugin would 
likely crash upon Liveconnect initialization. That is bug 5105.
(Assignee)

Comment 16

19 years ago
This works for me.  I just tried it with the latest plugin module fixes and the 
newly-patched Java Plug-In from Sun.  Works like a charm.  I'm marking this bug 
FIXED, awaiting verification.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
Verified in the 2000030609 build.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.