Links randomely cause zombie thread which must be killed with Task Manager

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208 Firebird/0.7+

The behavior seems to have become worse a few weeks ago. If I click on a link
(or open a bookmark, or allow SessionSaver to restore a link, etc.) and it does
not resolve (Correctly? In time? ???), the throbber and the spinner on the tab
continue to spin forever. (What used to happen was the link was unavailable
until you reloaded the page. However, all other links worked normally.) If you
click another link, or hit STOP, or hit RELOAD, you are hosed becaue no other
link will work until you restart the browser. All menus work and respond
normally. If you click on the "Red X" to close Firebird, the window closes
immediately. However, if you attempt to restart Firebird, you get an error that
someone is already using your profile. You must use Task Manager to kill the
zombie Mozilla thread. Now you can restart Firebird.

I am using a P4 with HyperThreading turned on. I cannot find it now, but I saw
an entry in a thread on Mozillazine where someone suggested the zombie thread
might be caused by a problem with hyperthreading. 

Reproducible: Sometimes

Steps to Reproduce:
There is no known reliable way to reproduce the problem.  It *seems* to be
related to network load.  The behavior is as if a link is unable to resolve or
load correctly (or in time).  However, this exact same link and page will load
correctly most of the time.  Very frustrating.
Actual Results:  
When the bug does happen, the throbber and tab spinner continue to animate
forever.  Clicking on any link, selecting a bookmark, clicking on STOP or
RELOAD, does nothing to resolve the problem.  No matter what you do (even if you
have multiple Firebird windows open) will allow you to browse to any other page.
 You must close Firebird and then kill the zombie thread before you can restart
Firebird.

Expected Results:  
If a link cannot be resolved correct, an error should be generated.
If a link cannot be resolved in time, an error should be generated.
Regardless of cause, the user should be able to click on any other link, select
a bookmard, or RELOAD the page successfully.  When Firebird is closed, there
should be no remaining zombie threads.

At times, the problem happens more frequently.  It is possible this is due to
network load on my PC.  The problem eventually happens EVERY TIME I try to use
Firebird.  I have tried many different versions (both standard and optimized)
and the problem remains.

Could this be related to P4 HyperThreading???

(No other application has this problem.)
(Reporter)

Comment 1

15 years ago
Below are comments I added for Bug 221429 which I thought was the same problem.
 I just realized it was filed under Linux which is NOT what I am using.  Sorry
for the mistake.

----------

Is there a possibility a thread bug exists in either the MS compiler/libs or the
Firebird code?  Could this problem be related to one of the MANY MS critical 
updates to patch the security holes?

----------

One of the pages that exhibits this the most is my Excite home page
(www.excite.com) with the signon cookie in place so it actually loads my
preferences.  I can now say, for sure, my problem is caused by an address that
cannot be resolved. I disabled all extensions to be sure they were not involved.
I could repeat this sequence:

1) Start Firebird
2) Page begins to paint, very slowly
3) Page stops updating (still unfinished)
4) The Tab (only one open) has the spinner going and the title "Loading..."
The Status Bar says "Resolving host webdog.staff.iwon.com..."
5) Click STOP
The Status Bar says "Stopped"

At this point it does not matter whether you click RELOAD, Select a bookmark,
click GO, etc.
You are stuck. Even though the throbber and tab spinner stops and starts as you
would expect, the Status Bar never changes. It says "Stopped" no matter what you
do. If you close Firebird, you still need to go to Task Manager and kill the
zombie thread before you restart it.

I did a quick ping of this link and received the following:
"Ping request could not find host webdog.staff.iwon.com. Please check the name
and try again."
Ping gave me this message IMMEDIATELY.

Firebird seems to have a problem with addresses that have an unresolvable host.

Could this also be related to a Javascript problem?

(BTW, the only way I could use Firebird to enter this text was to hit STOP as
soon as Firebird appeared after a restart. It did not have a chance to get stuck
on the unresolvable address.)

----------

I just installed the 20031216 standard nightly and the problem persists.  NO
extensions loaded.

Comment 2

15 years ago
i can confirm that i am seeing the same problems on the latest nightlies while
running hyperthreading.  when HT is off, the pages seem to load fine or give an
error instead of going 'zombie'.

Comment 3

14 years ago
I have been seeing this behaviour recently.  I am using: Firefox 1.0, Windows XP
SP2, notebook with Via Antaur processor.

The web site that is causing me most grief is 'www.carsales.com.au', when
selecting options from the pulldown menus on the main page.
Reproducible:  The fault occurs on the specified web site about half of the time.

Note: two Java icons appears on the task bar (Java 2 Platform SE, Version 1.5.0
(build 1.5.0-b64)).  When zombie process killed only one Java icon remains.

Comment 4

14 years ago
I am also seeing this behavior (started when upgraded to 20050414 Firefox/1.0.3)
This behavior appears only when I am in a Windows session (XP Professional SP2,
Gateway Laptop, P4, 3.0 GHz, 512MB ram).  Same computer has a Linux partition in
which this behavior does not occur.  One site that can cause problems is
http://www.allstarpuzzles.com/picture/index.html (any of the puzzles off that
page)  Windows installation is running Java 1.5.0 (build 1.5.0_02-b09)

Comment 5

13 years ago
I see this problem every few days, usually following moderately heavy browsing
at Yahoo News. I have been unable to find a specific page that triggers it. When
it occurs Mozilla refuses to load any further links and the dot on the cursor
stops blinking. I can still close windows, but when I close the last one the
Mozilla process refuses to exit, and I have to end it.

I am using Mozilla 1.7.12, but have seen this at least as far back as 1.7.10,
and probably much earlier. I do not have HTTP pipelining enabled, though I do
have HTTP 1.1 enabled. I have just switched to HTTP 1.0 to see whether that ends
the problem.

Comment 6

13 years ago
(In reply to comment #5)
> and the dot on the cursor stops blinking. <

That should read: "and the dot on the *tab* stops blinking".

Comment 7

13 years ago
(In reply to comment #5)
I have turned off HTTP keepalive, and the problem still occurs. I am now trying
HTTP 1.0 with no keepalive.

Comment 8

13 years ago
(In reply to comment #7)
> I have turned off HTTP keepalive, and the problem still occurs. I am now trying
> HTTP 1.0 with no keepalive.

The problem still occurs. In summary, the problem occurs with all combinations
of pipelining, HTTP 1.1/1.0, and keepalive.

Comment 9

13 years ago
(In reply to comment #2)
> i can confirm that i am seeing the same problems on the latest nightlies while
> running hyperthreading.  when HT is off, the pages seem to load fine or give an
> error instead of going 'zombie'.

My machine is an AMD Turion MT-37, which does not support hyperthreading, so
that's probably not the cause -- unless we're seeing two different bugs that
produce the same effects.
Assignee: bross2 → nobody
QA Contact: general
(Reporter)

Comment 10

11 years ago
The bad news: I forgot all about this bug.  (My apologies.)
The good news: I cannot remember the last time this bug occurred.  (Hooray!)

Unfortunately, I have no idea which version of Firefox corrected the problem.  The problem is gone (for me).

I am currently using the following version with no problem:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Thanks to whomever corrected this!
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.