Closed Bug 228648 Opened 19 years ago Closed 19 years ago

Crash on startup in 20031214+ (due to previously installed extensions?)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: klassphere, Assigned: bugzilla)

Details

(Keywords: crash, regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031211 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031211 Firebird/0.7+

Got immediate crash on startup with zip-installed 20031214 and 20031215 nightly
build on WinXP.
It crashed in rendering startup page (for me it's Google).
As 20031213 nightly runs ok for me, it must be caused by a checkin of that day.
FYI this crash is different from bug 205769.

Reproducible: Always

Steps to Reproduce:
Works fine for me

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031215 Firebird/0.7+
Keywords: crash, regression
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216
Firebird/0.7+ works for me now with Google as the startup page, but not sure
what has changed from before.
reproduceable on WinXP using 2003-12-16 Builds- both zip and installer. Cleaned
out install dir, but no effect. Still using profile dir tho.

WinXP ATI AllInWonder Radeon
I'm nominating this for blocking0.8 because it got 5 votes in 4 days and
completely stops these users from using Firebird.  (I assume that's 5 affected
users.  If you're not seeing this bug, you shouldn't be voting for it :P)

Someone who sees this bug needs to attach a stack trace.

http://www.gemal.dk/mozilla/build.html explains how to build Mozilla on Windows
using gcc and other free tools.  Expect it to take 1-2 hours of work and 3 hours
of waiting.

I build using MSVC (not free), so I can't help with every step of the building
process.   From my experience building other things with gcc on Windows, you can
get useful stack traces by just crashing and looking at a file that creates, and
you can get useful stack traces with gdb as long as you include -ggdb.

Official builds are made with MSVC, but many crashes don't depend on which
compiler you use.
Flags: blocking0.8?
The good old filemon ( http://www.sysinternals.com/ntw2k/source/filemon.shtml )
could be useful to narrow the bug down without resorting first to debugging.
Maybe it's just a file access problem ...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031217
Firebird/0.7+

Got the build from latest 0.8 folder on ftp.

With old profile and ext, starting mozilla caused process to start but hang.
Cant see no window.

Starting Fb with new profile starts FB with no prob. However noticing that
doesnt seem to remember settings (changed smooth scroll and find as you type in
settings)when closed and restarted. It seems to make a backup copy of prefs
file, for eg prefs-3.bak
Flags: blocking0.8? → blocking0.8+
Flags: blocking0.8+ → blocking0.8?
Installed FB on a clean profile. Installed WebDev, Paste and Go ext. Restarted
no problem.

Installed Autoscroll, Flast Click to View ext. Crashed during or just after
install of Flash ext.
Try attaching various parts of your profile (not your signon file or anything
sensitive)... and I can debug. 
Upon investigation I have to say it wasnt my profile that was causing the crash.
It was the probably the extentions that were installed in my FB app dir. When I
delete the FB install dir and start firebird with my old profile, it starts up
fine. FB forgets all the extentions...but it starts and works fine.

I dont remember which extentions were installed in profile and which ones in app
dir. Whicle we are on the topic of extentions, I think we could use more
rigorous standards for them. 

Sorry didnt help much.
I've heard reports of the latest TBE (tabbed browser extensions) crashing the
browser on startup. If everyone experiencing this crash is using TBE then this
is probably the cause.

Could everyone who is experiencing this problem check what extensions are
installed, list them here and try again with a new installation/profile to see
if the bug still appears?

This could help solve this bug quickly.
This is probably a diff bug, but in build Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+ (probably all 0.8 builds) I
cant install more than 1 extention at a time. I had reported that FB crashed on
installing Flash CLick to view earlier. I think it is because it was the 2nd
extention I tried to install in a row.

I have to restrt every time i install an extention...which sucks. But I am
guessing this will not be the case when 0.8 release comes out.
I had CuteMenus, IE View, and EditCSS extensions installed.  After I removed IE
View jar file from my profile Fb loaded with no problem.  As an aside about that
particular extension, even though it was installed to my profile I had to
reinstall it with every new nightly.  For some reason Firebird would not
recognize that particular extension.  CuteMenus and EditCSS seem to still be
working without causing any issues.
#11 is a different bug (which needs filing if its not been already - but please
search first, I've heard other people talk about this problem).

#12 seems to indicate that this bug is an extension problem, not a Firebird
problem so should be marked invalid - Firebird is still a beta product; things
change and extension authors need to keep up.
#9: It has always been said that one should never install a newer version of
firebird over a previous install. You should completely remove the old
directory, and then do a fresh install.
Someone with permissions please update the summary to:
"possible crash on startup if previous install included extensions"
Comment 11 is bug 228986, "XPInstall - crash after installing two extensions
without restart".

Comment 12 implicates the IE View extension.  Can any other extensions cause
this crash?  If so, which extensions?
Summary: Immediate crash on startup on Windows (20031214 nightly) → Crash on startup in 20031214+ (due to previously installed extensions?)
per ben on IRC
Flags: blocking0.9?
Flags: blocking0.8?
Flags: blocking0.8-
Latest (3/19) linux nightly (non-gtk): If I try to install any extension (goup
for example), firefox won't render *anything* (no window at all) the next time I
start it.  If I then delete chrome.rdf, it's ok, but the extension won't show up
as installed and won't work.
sorry to spam... previously indicated behavior does NOT repro with clean profile
I haven't seen any updates on this in months, I don't think this is reproducable
at this point, resolving WORKSFORME, please reopen or file a new bug if there's
something not caused by bad extensions.
Status: NEW → RESOLVED
Closed: 19 years ago
Flags: blocking0.9? → blocking0.9-
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.