crash or 100% CPU on start up

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: phil, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

I started the computer this morning and logged in. I have Thunderbird set as a
startup application. When TB didn't appear, I used Start | Email. When nothing
showed up again, I looked in the task manager. There were two instances of TB,
one was running at 100% CPU utilization. I killed this instance (End Process),
and both died. I then tried to restart the application (Start | Email), but got
a "program is dead, do you want to tell MS about it" message. I didn't tell them :-)

I tried starting and got a couple more such messages before I decided to reboot.
After the reboot, I have a TB process running at 100%, varying between around
18-21 MB mem usage. I've killed it again.

Oh ****. It just restarted, and is now working fine. File it under can't
reproduce? Dunno. Thought you might want to know anyway.

Reproducible: Sometimes

Steps to Reproduce:
1. Try and start TB

Actual Results:  
As described in the details.

Expected Results:  
Started.

I have 6 mail accounts, with about 180MB of mail data according to the file
system (Application Data\Thunderbird\Profiles...). A lot of the mail was
migrated from Outlook about a month ago, and I've been running fine since then.

When I looked in the analysis from crash report, I think it said it had died in
js3250.dll. I didn't write it down, but I remember it started with 'j'.

I'm using the default theme, the main window opens on the Main Email Account Inbox.

I've installed Enigmail, but when I try to send a message, it says that it
"Failed to initialize Enigmail. Send unecrypted message?". Probably unrelated.

Comment 1

15 years ago
Smells like it is related to enigmail. You can cure this by cleaning your
profile -> removing chrome directory and xul.mfl.

Can you also try to see if with Thunderbird 0.5 and the latest enigmail said to
be compatible with thunderbird 0.5 you're still having a crash ?

Thanks.

Comment 2

15 years ago
This problem also exists with the MacOS X version of the Thunderbird.
Especially when multiple programs are being launching including the Thunderbird,
it makes the MacOS X frozen.

I noticed this problem with recent version, and currently the version I have is
April, 26.

Comment 3

14 years ago
I can reproduce the problem constantly on two computers, P4@2.4G XP Pro SP2 and
PM 1.4G, XP Home SP2.

In older versions it helped, if I replaced all references to thunderbird in
registry from DOS-8.3 file names to long ones (I mean
C:\PROGRA~1\MOZILL~2\THUNDE~1.EXE -> C:\Program Files\Mozilla
Thunderbird\thunderbird.exe)

In version 1.0, it helps, but only if I do not use startup profile selection. If
startup profile selection is active, I get to to selection, but after selecting,
CPU100% and nothing further. if I launch "thunderbird.exe -p xxx", it starts up OK.

If I manage to launch thunderbird and click set thunderbird as default mail app,
registry is modified back to DOS-8.3 names and I can't launch thunderbird any
more from Start/mail.

Comment 4

14 years ago
Can this be SP2 related somehow??

(system specs: dell latitude, 1.7Ghz Pentium-M, 512MB, XP Pro SP2)

I was running thunderbird 0.9 happily for months. However suddenly last week it
maxed out the CPU right after startup. The gui is visible, but that's all. No
mailheaders visible. CPU at maximum.
So the first obvious thing I tried was installing 1.0 ... installation OK, my
profile and all mailaccounts still existed, so I cheered :) Untill.... I saw the
CPU graph again. At max. Hence TB not responding either. 
This is bugging me, since I'm not able to use TB now, and I don't want anything
else :(

After thinking about it a few days, and reading the response here by Rene, I
noticed he is also running xp SP2. Then it came to me.... I installed XP2 last
week!!!!

Comment 5

14 years ago
After completely deleting my profile, TB starts properly again.
Not really a convenient 'sollution' though...
I saved a backup copy of the profile, so I can try/test things if desired. Just
let me know.

Comment 6

12 years ago
Rene, 
very odd description indeed. please supply the full build string from help>about - for example "version 1.5.0.5 (20060719)" - you should be at at least v1.5.something.

Comment 7

12 years ago
I'm using 1.5.0.5 (20060719).

Comment 8

12 years ago
Cairns: "As I recall, I hadn't seen the 100% CPU on startup error for quite some
time, though. ... [but] I'm using Outlook now."
so marking this bug WFM

Rene, thanks for the update. Based on available info and especially your description in comment 3, your problem is not related this the original bug report.  Suggest you :
* start with a clean profile and start TB with that profile in safe mode
* seek advice in forum http://forums.mozillazine.org/viewforum.php?f=39
* if you still have a problem then file a new bug with a talkback stack from the crash.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.