Printing fails with XPSERVERLIST not set

RESOLVED DUPLICATE of bug 195065

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 195065
15 years ago
14 years ago

People

(Reporter: Leslie Wood, Unassigned)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031015 Firebird/0.7
Build Identifier: Mozilla 1.6b and Thunder bird 0.7

Using the "File/Print" option on Solaris 9 with Mozilla 1.6b results in a
popup window with this message:

There was a problem printing.  No Xprint server(s) could be found.
Check wether the XPSERVER list environment variable contains any valid Xprint
servers.

All prior versions of Mozilla used the Solaris softprint defaults without
a problem via the users "~/.printers" file.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Use Solaris native printing

Comment 1

15 years ago
From
http://www.mozilla.org/releases/mozilla1.6b/installation-ports.html#ports_solaris
> # Requires Xprint to be installed for printing. xprint.mozdev.org provides the
GISWxprint  (or GISWxprintglue) package as drop-in way for installation
the old way of printing is no longer be supported - too many bugs, no support
for internationalization, no euro support, no maintainer, no one looking at bugs
and no hope.

Comment 2

15 years ago
That's a bit overstated. The postscript printing module has some serious flaws,
but it does work. It's receiving some maintenance, and there are no plans to
drop it from mozilla.

The issue here is that one of the solaris builds provided by mozilla are built
without the postscript printing module. These builds are contributed builds,
meaning they're contributed by an outside volunteer rather than being the
responsibility of the mozilla organization, and the contributor has chosen to
provide these builds with only the Xprint printing module.

If you'll check
<http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6b/>, there
are actually two solaris builds of 1.6b available from mozilla.org. I haven't
downloaded it to check, but it looks like
mozilla-sparc-sun-solaris2.8_1.6b.tar.gz (note the underscore) should contain
both printing modules.

For further discussion of these issues, see bug 195065.

*** This bug has been marked as a duplicate of 195065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
> That's a bit overstated.
No, this is not overstated. Search bugzilla. Make your own tests. Face the
reality that your beloved pet is not the runner. Follow the discussion in the
web. I doubt that anyone except RedHat and the Mozilla Foundation will support
that way of printing in 2 - 3 years.
> The postscript printing module has some serious flaws,
> but it does work. It's receiving some maintenance, and there are no plans to
> drop it from mozilla.
Thats **** with bechamel. Where is the 'maintaince' you are talking about?
Since 2 years Mozillas so called 'default Postscript driver' is unable to print
on HP printers and HP customer support is **** ANGRY about about the TOTAL
INABILITY of mozilla to produce Postscript code which works with their printers.
For Lexmark and Tek printers similar bugzilla bugs exist. Either you provide
solutions for the problems or accept that this part of Mozilla fades out.

Comment 4

15 years ago
David,

We have bug reports about printing on HP and Tek postscript printers, and I
don't doubt that there's a real problem, but I can't reproduce it on the one HP
printer I have access to. If HP, Tek, or Lexmark have any information or
assistance to offer on the subject, it'd be welcome. Further comments on this
subject should go on one of the relevant bugs, e.g. bug 176938.

Comment 5

14 years ago
(In reply to comment #4)
> David,
> 
> We have bug reports about printing on HP and Tek postscript printers, and I
> don't doubt that there's a real problem, but I can't reproduce it on the one HP
> printer I have access to. If HP, Tek, or Lexmark have any information or
> assistance to offer on the subject, it'd be welcome. Further comments on this
> subject should go on one of the relevant bugs, e.g. bug 176938.

Why should I bother wasting time with dead code? LTSP, Debian, Mandrake - they
all build without the postscript printing module now or the next major release
will get rid of it, other Linux distributions will follow that lead. Except
RedHat of course but that company lives behind the moon anyway.
You need to log in before you can comment on or make changes to this bug.