Infoworld crashes Viewer

VERIFIED DUPLICATE of bug 2245

Status

()

P1
critical
VERIFIED DUPLICATE of bug 2245
20 years ago
12 years ago

People

(Reporter: mikepinkerton, Assigned: troy)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Going to www.infoworld.com crashes the mac viewer deep down in layout.

PowerPC access exception at 037FEB70
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  03881F44
  04266600    PPC  0386A0A8  main+0008C
  042665B0    PPC  03869908  nsNativeViewerApp::Run()+00034
  04266570    PPC  059B9658  nsAppShell::Run()+00108
  04266490    PPC  059B9DAC  nsMacMessagePump::DoMessagePump()+001C4
  04266430    PPC  05A5A0D0  LPeriodical::DevoteTimeToRepeaters(const
EventRecord&)+00048
  042663D0    PPC  05F0CF20  TimerPeriodical::SpendTime(const EventRecord&)+00070
  04266370    PPC  05F0C924  TimerImpl::Fire()+00030
  04266330    PPC  05D811F8  nsNetlibService::NetPollSocketsCallback(nsITimer*,
void*)+0004C
  042662F0    PPC  05D5A0D0  NET_PollSockets+000BC
  042662A0    PPC  05D54FC8  NET_ProcessNet+00520
  04265F00    PPC  05D78EAC  net_ProcessHTTP+00114
  04265A80    PPC  05D78724  net_pull_http_data+0011C
  04265A30    PPC  05D7AAD8  net_ChunkedWrite+001A4
  042659C0    PPC  05D48F34  net_MemCacheWrite+002BC
  04265950    PPC  05D84C7C  stub_put_block(_NET_StreamClass*, const char*,
long)+000D8
  04265900    PPC  05B3D1EC  nsDocumentBindInfo::OnDataAvailable(nsIURL*,
nsIInputStream*, un
signed int)+000BC
  042658A0    PPC  059782D8  nsParser::OnDataAvailable(nsIURL*, nsIInputStream*,
unsigned int
)+00254
  04265830    PPC  05977CB0  nsParser::ResumeParse(nsIDTD*)+000BC
  042657E0    PPC  05969434  CNavDTD::WillInterruptParse()+00034
  042657A0    PPC  03600B58  HTMLContentSink::WillInterrupt()+0006C
  04265760    PPC  03606D1C  nsHTMLDocument::ContentAppended(nsIContent*, int)+
000F4
  04265710    PPC  035D9DE0  nsDocument::ContentAppended(nsIContent*, int)+00054
  042656C0    PPC  035E81C8  PresShell::ContentAppended(nsIDocument*, nsIContent*
, int)+00064
  04265680    PPC  035E6594  PresShell::ExitReflowLock()+00034
  04265640    PPC  035E7AAC  PresShell::ProcessReflowCommands()+00154
  042655B0    PPC  036705E0  nsHTMLReflowCommand::Dispatch(nsIPresContext&,
nsHTMLReflowMetri
cs&, const nsSize&, nsIRenderingContext&)+0017C
  042654F0    PPC  0367BAA8  RootFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const n
sHTMLReflowState&, unsigned int&)+003DC
  04265390    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  04265330    PPC  03671820  nsScrollFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+004C4
  04265140    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  042650E0    PPC  037FC41C  nsAreaFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+00420
  04264FB0    PPC  0379C864  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00040
  04264F60    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  04264590    PPC  0379DA00  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00038
  04264540    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  042644B0    PPC  03795E60  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+001AC
  04264430    PPC  037970F0  nsBaseIBFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
 int&)+003B4
  042642B0    PPC  037F3340  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 unsigned int&)+002CC
  042641C0    PPC  0379C864  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00040
  04264170    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  042637A0    PPC  0379DA00  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00038
  04263750    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  042636C0    PPC  03795E60  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+001AC
  04263640    PPC  037970F0  nsBaseIBFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
 int&)+003B4
  042634C0    PPC  037F3340  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 unsigned int&)+002CC
  042633D0    PPC  036652F0  nsTableOuterFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&,
 const nsHTMLReflowState&, unsigned int&)+00488
  042630E0    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  04263080    PPC  0365A0F0  nsTableFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00558
  04262FA0    PPC  0365AB14  nsTableFrame::ResizeReflowPass2(nsIPresContext&,
nsHTMLReflowMet
rics&, const nsHTMLReflowState&, unsigned int&)+0021C
  04262EF0    PPC  0365CC08  nsTableFrame::ReflowMappedChildren(nsIPresContext&,
nsHTMLReflow
Metrics&, InnerTableReflowState&, unsigned int&)+00340
  04262CF0    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  04262C90    PPC  0366CA98  nsTableRowGroupFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetric
s&, const nsHTMLReflowState&, unsigned int&)+001B4
  04262C00    PPC  0366B854
nsTableRowGroupFrame::ReflowMappedChildren(nsIPresContext&, nsHT
MLReflowMetrics&, RowGroupReflowState&, unsigned int&, nsTableRowFrame*,
nsReflowReason, int)
+00248
  04262AD0    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  04262A70    PPC  0366A2D4  nsTableRowFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, c
onst nsHTMLReflowState&, unsigned int&)+00298
  04262960    PPC  03667DF4  nsTableRowFrame::ResizeReflow(nsIPresContext&,
nsHTMLReflowMetri
cs&, RowReflowState&, unsigned int&)+004B0
  04262750    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  042626F0    PPC  0364DC10  nsTableCellFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&,
const nsHTMLReflowState&, unsigned int&)+003FC
  042624F0    PPC  035D5AF8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+000B4
  04262490    PPC  037FC41C  nsAreaFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+00420
  04262360    PPC  0379C864  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00040
  04262310    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  04261940    PPC  0379DA00  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00038
  042618F0    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  04261860    PPC  03795E60  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+001AC
  042617E0    PPC  037970F0  nsBaseIBFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
 int&)+003B4
  04261660    PPC  037F3340  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 unsigned int&)+002CC
  04261570    PPC  0379C864  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00040
  04261520    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  04260B50    PPC  0379DA00  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00038
  04260B00    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  04260A70    PPC  03795E60  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+001AC
  042609F0    PPC  037970F0  nsBaseIBFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
 int&)+003B4
  04260870    PPC  037F3340  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 unsigned int&)+002CC
  04260780    PPC  0379C864  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+00040
  04260730    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  0425FD60    PPC  0379DA00  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00038
  0425FD10    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  0425FC80    PPC  03795F38  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+00284
  0425FC00    PPC  037975A0  nsBaseIBFrame::ReflowInlineFrame(nsBlockReflowState&
, nsLineBox*
, nsIFrame*, int&, int&)+000A8
  0425FB80    PPC  037A7024  nsInlineReflow::ReflowFrame(nsIFrame*, int, unsigned
int&)+00120
  0425FAF0    PPC  037A75D4  nsInlineReflow::ReflowFrame(int,
nsHTMLReflowMetrics&, unsigned
int&)+00200
  0425FA10    PPC  037944B0  nsBaseIBFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002D0
  0425F040    PPC  037955B8  nsBaseIBFrame::ReflowDirtyLines(nsBlockReflowState&
)+00068
  0425EFB0    PPC  03796090  nsBaseIBFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int&)
+003DC
  0425EF30    PPC  03798298  nsBaseIBFrame::PlaceLine(nsBlockReflowState&,
nsLineBox*, int&)+
003B0
  0425EE90    PPC  0379ABA0  nsBlockReflowState::ClearFloaters(int, unsigned
char)+00034
  0425EE50    PPC  037F677C  nsBlockBandData::ClearFloaters(int, unsigned char)+
00028
  0425EDD0    PPC  037F60D4  nsBlockBandData::GetAvailableSpace(int)+0003C

Comment 1

20 years ago
This is almost certainly a duplicate of 2159 ("[PP] macweek, infoworld crashes
Mac Viewer (same root, but can't decompose further)")
(Reporter)

Updated

20 years ago
Hardware: Macintosh → PC
Summary: [PP] Infoworld crashes Viewer → Infoworld crashes Viewer
(Reporter)

Comment 2

20 years ago
Yes, it is. I didn't look closely at the bug before i filed it. my bad. However,
this happens on 1/11/98 win32 build as well (debug). So it's probably not a PP
bug, marking platform PC, but can't mark it Win95/98/NT because bugzilla won't
let me.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

20 years ago
*** This bug has been marked as a duplicate of 2245 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Verified duplicate of 2245.

Updated

17 years ago
Hardware: PC → Macintosh
You need to log in before you can comment on or make changes to this bug.