If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Preference panel(s): 'onload' event handling cleanup

RESOLVED FIXED in mozilla1.7beta

Status

SeaMonkey
Preferences
--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
mozilla1.7beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

14 years ago
Spun off of bug 226958 comment 42.
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

14 years ago
Created attachment 137677 [details] [diff] [review]
(Av1) <pref.xul ++>
[Checked in: see Comment 8 and 9]
(Assignee)

Updated

14 years ago
Attachment #137677 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

14 years ago
From LXR:

 18  * Contributor(s):
 19  *   Ben "Count XULula" Goodger <ben@netscape.com>

 27  *  =>> CHANGES MUST BE REVIEWED BY ben@netscape.com!! <<=

Is this address (Ben Goodger) still correct?
(Assignee)

Comment 3

14 years ago
I guess it's now 'ben#bengoodger.com', from
<http://www.mozilla.org/hacking/reviewers.html>.
But this has to be confirmed...
(Assignee)

Comment 4

14 years ago
ben#bengoodger.com:

> 19  *   Ben "Count XULula" Goodger <ben@netscape.com>

Do you want this line updated ?

> 27  *  =>> CHANGES MUST BE REVIEWED BY ben@netscape.com!! <<=

Do you want this line updated/deleted ?
Do you want to be the reviewer ?
Target Milestone: --- → mozilla1.7alpha
(Assignee)

Updated

14 years ago
Target Milestone: mozilla1.7alpha → ---

Comment 5

14 years ago
Comment on attachment 137677 [details] [diff] [review]
(Av1) <pref.xul ++>
[Checked in: see Comment 8 and 9]

r=me although some of the indentation looks odd, is there a reason for that?
Attachment #137677 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Comment 6

14 years ago
Comment on attachment 137677 [details] [diff] [review]
(Av1) <pref.xul ++>
[Checked in: see Comment 8 and 9]


Re comment 5:

I used a 2-char indentation:

|onAccept:| is lined up with |onload:| and |openBranch:|;
the 2 |return true;| looks odd because the existing code is "more" indented
than "needed".

I could change this if requested...
Attachment #137677 - Flags: superreview?(alecf)

Comment 7

14 years ago
Comment on attachment 137677 [details] [diff] [review]
(Av1) <pref.xul ++>
[Checked in: see Comment 8 and 9]

sr=alecf
Attachment #137677 - Flags: superreview?(alecf) → superreview+

Comment 8

14 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

14 years ago
Comment on attachment 137677 [details] [diff] [review]
(Av1) <pref.xul ++>
[Checked in: see Comment 8 and 9]


(for the record)
The |<separator/>| removal was done in bug 223295 in the meantime.
Attachment #137677 - Attachment description: (Av1) <pref.xul ++> → (Av1) <pref.xul ++> [Checked in: see Comment 8 and 9]
Attachment #137677 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Target Milestone: --- → mozilla1.7beta
Might Bug 236467 have been caused by this bug (the regression window would fit)? 
ccing neil, cause he might know better...
(Assignee)

Comment 11

14 years ago
(In reply to comment #10)
> Might Bug 236467 have been caused by this bug (the regression window would fit)? 

(I doubt it, but:)

> ccing neil, cause he might know better...

See also bug 236467 comment 11.
(Assignee)

Comment 12

14 years ago
(In reply to comment #10)
> Might Bug 236467 have been caused by this bug (the regression window would fit)? 

It seems unrelated, per bug 236467 comment 19:
{{
this bug is not limited to the preferences window
}}
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.