Troubleshooting link in Help Welcome screen is broken

VERIFIED FIXED in mozilla1.7alpha

Status

Documentation
Help Viewer
--
minor
VERIFIED FIXED
15 years ago
7 years ago

People

(Reporter: Dan, Assigned: R.J. Keller)

Tracking

unspecified
mozilla1.7alpha
x86
Windows 2000

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

Two links on the main page in the help file (Help > Help Contents) have broken
links. These are 'Troubleshooting' and 'Quality feedback agent'.


Reproducible: Always

Steps to Reproduce:
1. Choose Help > Help Contents
2. Click on Troubleshooting (second link under Help on the Web on the left hand
side on the page) or Quality Feedback Agent (bottom link).

Actual Results:  
404 errors.


Expected Results:  
Go to the right page.


Troubleshooting - http://www.mozilla.org/start/1.5/troubleshooting/ - doesn't exist.
Quality Feedback Agent - http://www.mozilla.org/qualify/qfa.html - typo (qualify
in place of quality).
(Assignee)

Comment 1

15 years ago
Reporter, the Troubleshooting link was already fixed in another bug.

Daniel, do you know of any plans to have
http://www.mozilla.org/start/1.5/troubleshooting/ posted? or maybe under 1.6?
I'm wondering if we should change the link back to 1.4 or change it to 1.6 or
keep it at 1.5.
(Assignee)

Comment 2

15 years ago
Asa: Do you know of any plans to add a mozilla.org/start/1.5/troubleshooting/ or
maybe start/1.6/troubleshooting? I'd like to know which one of these Help should
link to for 1.6, or maybe some other link?

Nominating for blocking1.6. Usually I wouldn't make this a blocker, but this is
a huge link to be dead in help and it shouldn't be dead in the final release. It
would confuse users and make it harder for them to find troubleshooting tips.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: blocking1.6?
Summary: Help file has two broken links on first page → Troubleshooting link in Help Welcome screen is broken

Comment 3

15 years ago
Can someone port http://www.mozilla.org/start/1.4/troubleshooting/ forward to
the /1.5 dir on gila?
(Assignee)

Comment 4

15 years ago
--> Doc: User
Component: Help → User
Product: Browser → Documentation
Target Milestone: --- → mozilla1.7alpha
Version: Trunk → unspecified

Comment 5

15 years ago
myk, there's a bogus "Troubleshooting" directory in mozilla-org/html/start/1.5/
preventing me from checking in "troubleshooting/*" files (note the case). Can
you remove it?
I copied the 1.4 troubleshooting files to 1.5.  (I guess you can't do that on
windows since the filesystem is case-insensitive.)
(Assignee)

Comment 7

15 years ago
Marking bug fixed, since it appears to have fixed itself with dbaron's checkin
of the 1.5 start page.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Status: RESOLVED → VERIFIED
And nobody is worried about the fact that 1.6 help will be pointing to the 1.5
start page?
(Assignee)

Comment 9

15 years ago
hmm. Good point! file a bug!

I won't have time to fix this until the weekend, so filing a bug will remind me
:). If you don't have time, email me and I'll file one.

Comment 10

15 years ago
dbaron, that would be bug 224351 . We don't want to have too many start pages.
You need to log in before you can comment on or make changes to this bug.