Switching from single-line input to multi-line input should not lose the text in chatzilla

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Richard Corbin, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-patch][cz-0.9.68])

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

The input box in ChatZilla 0.9.52 should keep the text in it when you switch
from single-line input to multi-line input and vice versa.

Reproducible: Always

Steps to Reproduce:
1. Open ChatZilla
2. Join any channel
3. Type some text in to the single line input box.
4. Click the up arrow (or Ctrl + Up Arrow) to switch to Multi-line input.
5. Click the down arrow (or Ctrl + Down Arrow) to switch back to Single-Line input.

Steps 4 and 5 are swappable, i.e. the results occur whether switching one way or
other.

Actual Results:  
After performing step 4 the text disappears.
After performing step 5 the text re-appears.

Expected Results:  
After performing step 4 Chatzilla should show the text that was typed in step 3
in the multi-line input box.
(Reporter)

Comment 1

15 years ago
*** Bug 228965 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
confirmed in 0.9.54b.  Although sometimes rather than just disappearing, the
last/next typed line of text is produced (what pushing up or down alone does).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Dunno how you can expect multiple lines to be preserved when switching from
multi to single, but certainly it should preserve when switching from single to
multi.
(Reporter)

Comment 4

15 years ago
Felix, multiple lines could be concatenated as follows:

Multiple Lines:
i)   This is the first line,
ii)  Second line,
iii) and third line

Would be transformed to:
This is the first line,<SPACE>Second line,<SPACE>and third line

Spaces would need to be added where indicated above with <SPACE>

----

An alternative option would be to give the end user some choices using a message
box:
* Delete the text
* Concatenate the text
* Keep only the first line
[ ] Click here for Chatzilla to remember your choice and not ask you again
(Assignee)

Comment 5

15 years ago
or we could just keep the first line, and leave it at that.  we don't need to
get too complicated here.
(Reporter)

Comment 6

15 years ago
Agreed. I'm happy for you (rginda) to progress, keeping the first line only when
switching from multi-line to single-line.

Thanks, metz.

Comment 7

14 years ago
*** Bug 231858 has been marked as a duplicate of this bug. ***
Product: Core → Other Applications

Comment 8

13 years ago
Created attachment 180938 [details] [diff] [review]
Keep text when switching inputs

This loses the extra lines if you switch multi -> single -> multi, but is
otherwise fine.
Attachment #180938 - Flags: review?(rginda)

Updated

13 years ago
Whiteboard: cz-patch

Updated

13 years ago
Whiteboard: cz-patch → [cz-patch][cz-0.9.68]

Updated

13 years ago
Blocks: 299458

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Updated

13 years ago
Attachment #180938 - Flags: review?(rginda) → review?(samuel)

Updated

13 years ago
Attachment #180938 - Flags: review?(samuel) → review+

Comment 9

13 years ago
Checked in --> FIXED.

This doesn't preserve anything beyond the first line of multi-line text, but I don't think that is the main issue in this bug.

If someone really wants to extend it, then I suggest filing a bug with Severity: Enhancement for it.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.