Cookie Path does not function corectly

RESOLVED WORKSFORME

Status

()

Bugzilla
Installation & Upgrading
--
major
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: Ryan Little, Assigned: zach)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Under Parameters, it says to set "cookiepath:	Directory path under your document
root that holds your Bugzilla installation. Make sure to begin with a /." My
installation is under $WEBROOT/bugzilla, so I entered "/bugzilla" as the cookie
path. Doing so caused cookies to be inoperative. Setting cookiepath back to /
cases normal operation to resume.

Reproducible: Always

Steps to Reproduce:
1. Set "cookiepath" to /<Dir-Bugzilla-Is-In>
2. Log in to bugzilla.
Actual Results:  
Each time you perform an action you will have to log back in, because the cookie
path is incorrect.


Problem is corrected by:
1. Reset the cookiepath to /
2. Logins will function properly.
you need a slash on the end, too.  The parameter description has been fixed
already in cvs to clarify that.  Also to point out, if you change it, anyone
who's already accessed it when it was set to / needs to delete their cookies
before it'll work again.

See bug 220817 for lots of examples that'll soon be in the docs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.