Slow mail retrieval directing more than one account to the same folder - antivirus

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: sander.vandemoortel, Assigned: mscott)

Tracking

({perf})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: possible workaround: exclude mail directory from antivirus scan, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031122 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031122 Firebird/0.7+

I'm using an IMAP mail folder and everytime I launch thunderbird to check for
new mail, and if it indeed found new mail, it takes quite some time and the
system freezes for a short while, the harddisk rattling loudly.

I guess thunderbird rearranges its mail datafiles, but it takes too much time
and is quite annoying, for instance when burning a cd at the same time. It also
keeps me from opening thunderbird to quickly check my mail.

Reproducible: Always

Steps to Reproduce:
1. send mail to self
2. open thunderbird
3. watch your harddisk rattle a while
maybe this is solely the case for IMAP folders, I don't know.

Comment 1

15 years ago
POP3 retrieval is also very slow.
Keywords: perf

Comment 2

15 years ago
I've just logged bug 241793 on the MailNews component which sounds quite similar
to this one.

I ran the free www.sysinternals.com FileMon tool and you can see what is
happening in terms of disk activity during the "harddisk rattling" I experience.
 It may be worth comparing what you see.
(Reporter)

Comment 3

15 years ago
There really should be done something about it. I have no problems with this on
my laptop.

I just installed thunderbird on my dad's computer, (he has a POP account), and
there it takes ages to delete a message, yet flushing the trash folder is done
in a jiffy.

Comment 4

14 years ago
I see this too on my desktop. When I start Thunderbird, it sits there
unresponsive for minutes. Then it will not access my mail accounts. The login
prompt never is displayed.

It is fine on my laptop. I did a reinstall, but no joy.

Comment 5

13 years ago
Confirm this behaviour on: version 1.0.6 (20050716)

All operations outside selecting a message ie. opening, deleting, moving folders
etc. almost hang the computer for the time it takes to complete the operation.
Can not change windows, can not select another message while one is "opening" etc.

Started after I switched to a system with 64bit AMD processor, everything else
remained the same including the OS.

Have tried to reinstall and update from 1.0.4 but no avail.

Comment 6

13 years ago
things like this can often be caused by virus checking programs.

Comment 7

13 years ago
The comment about virus checking has no bearing on what I'm seeing
as there is none running. This problem began showing up around 1-2
weeks ago and is so severe I've gone back to Mozilla.

Using the recommended Filemon program I seem many repeated file
access patterns.

This is a show stopper for using Thunderbird, as it can take 30
seconds to load a message from an IMAP server and display it,
where Mozilla is near instantaneous.

Comment 8

13 years ago
I made an ticket to F-Secure to check whether they could be causing this
slowness on my personal case.

They said that this is a common problem when the mailfile is being accessed by
the mail client and virus scanner. In case of POP3 I did put the mail directory
to be exluded from real-time scanning and the problem went away.

Comment 9

13 years ago
Alas, I too am having this problem now. Even after revertin to older versions of Thunderbird which had worked fine.

Symptom is about 10-15 seconds of hard disk activity each time I open a message. It behaves as if, perhaps, the mail summary file is corrupt (even though I deleted the summary files and allowed rebuild and had same symptom), and that it does not contain valid 'pointers' to the data file's offset for the message, so that the data file must be linearly searched each time. That's how it seems to be, anyway.

Is it possible that a recent alpha build will have corrupted the expected syntax/offsets in my current datafiles?

If someone familar with the inards of the mail filesystem can suggest tests, I'd be happy to help diagnose this one.

Comment 10

13 years ago
Correction: The problem does not occur when I revert to Thunderbird 1.0.7. But any of my recent 1.5/1.6 alpha installers that I try do have this problme; so the issue appears not as much related to this bug (reported against MUCH earlier versions), but more related to the new 1.5+ builds.

Comment 11

13 years ago
if the summary file was getting regenerated, you'd see a status message to that effect.

This kind of issue almost always turns out to be a virus checker issue, or an issue with some program that's trapping file i/o. I run debug trunk builds all the time with pop3 messages and I never see this.

Comment 12

13 years ago
I am no longer have this problem with TB 1.5.x release builds.. I elect that this be marked FIXED.

Comment 13

13 years ago
I have the same problem as most: Thunderbird becomes unresponsive immediately after start. The older Thunderbird 1.0.7 was faster. If I disable my virus software the problem disappears. 

Comment 14

13 years ago
(In reply to comment #13)
> I have the same problem as most: Thunderbird becomes unresponsive immediately
> after start. The older Thunderbird 1.0.7 was faster. If I disable my virus
> software the problem disappears. 

David, is there an FAQ or KB item for such issues?
Severity: critical → major
Component: Account Manager → Mail Window Front End
Whiteboard: possible workaround: set virus scanner to exclude the mail directory

Comment 15

12 years ago
http://kb.mozillazine.org/Thunderbird_:_Issues_:_Folder_Being_Processed bullet items are relevant to some of the above comments - especially those going back a few years.


matthew redekopp in comment #13:
> I have the same problem as most: Thunderbird becomes unresponsive immediately
> after start. The older Thunderbird 1.0.7 was faster. If I disable my virus
> software the problem disappears. 

exclude your mail directory from virus scanning

Summary: Slow mail retrieval → Slow mail retrieval directing more than one account to the same folder.

Comment 16

12 years ago
Reporter: "I think it was solved by saving the different mail accounts to different folders instead of all to the same folder....I actually cannot remember what the exact problem was. I also do not use Thunderbird (gmail just does it for me) anymore so I can't really tell."

closing invalid as there is no testcase for original report and others were antivirus related. if anyone still sees a problem on a current release please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Summary: Slow mail retrieval directing more than one account to the same folder. → Slow mail retrieval directing more than one account to the same folder - antivirus
Whiteboard: possible workaround: set virus scanner to exclude the mail directory → possible workaround: exclude mail directory from antivirus scan
Version: unspecified → 0.9
You need to log in before you can comment on or make changes to this bug.