HTML comments are not closed in the right place

RESOLVED FIXED

Status

MozillaClassic
P3
major
RESOLVED FIXED
20 years ago
2 months ago

People

(Reporter: Wilson Afonso, Assigned: Nisheeth Ranjan)

Tracking

1998-03-31
x86
Windows 95

Details

(Reporter)

Description

20 years ago
Created by Wilson Afonso (wilson@zaz.com.br) on Wednesday, April 15, 1998 6:19:19 AM PDT
Additional Details :
Mozilla is failing to recognize te closing of a comment tag
under certain circunstances.  For example, the following
code: <br>
&lt;table&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment 1 &lt;!-- X --&gt;
ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment 2 &lt;!--X--&gt;
ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment 3 &lt;!-- X--&gt;
ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment 4 &lt;!--X --&gt;
ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment 5 &lt;!-- X ---&gt;
ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;tr&gt;&lt;td&gt;Comment
6&lt;!--X--&gt;ok&lt;/td&gt;&lt;/tr&gt;<br>
&lt;/table&gt;<br>

Show up as:<br>

Comment 1<br>
Comment 2<br>
Comment 3<br>
Comment 4<br>
Comment 5<br>
Comment 6ok<br>

Updated

19 years ago
Assignee: brendan → nisheeth
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Component: HTML to Text/PostScript Translation → Layout
(Assignee)

Comment 1

19 years ago
Accepting bug...
(Assignee)

Comment 2

19 years ago
*** Bug 230 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

19 years ago
This bug existed in the old layout engine.  Marking wontfix because we have
moved over to doing the 5.0 browser around NGLayout, the new layout engine.
This bug does not exist in NGLayout.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Marking Verified/Won't Fix

Comment 5

12 years ago
*** Bug 315353 has been marked as a duplicate of this bug. ***

Comment 6

2 months ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/12d8e35c31398bdb625e6f8a5d6e61de48283f16
Fix issue #229, styling rules for interactive editor survey link

https://github.com/mozilla/kuma/commit/2557a32c4f6edf908f966c7b89916f59b92861a4
Merge pull request #4380 from schalkneethling/issue#229-styling-for-survey-link

Fix issue #229, styling rules for interactive editor survey link

Updated

2 months ago
Status: VERIFIED → RESOLVED
Last Resolved: 19 years ago2 months ago
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.