Location bar loses cursor focus in midst of typing if form with text input box is loaded.

VERIFIED DUPLICATE of bug 125282

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 125282
14 years ago
10 years ago

People

(Reporter: Josh Staiger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

If typing in an address in the URL bar while loading a page that contains a form
that specifies that the cursor should initially be placed in a certain text box
on the form, then when the page is finished loading, in the midst of typing your
address, the cursor will jump to the initial text box on the form, causing you
to have only "half" a url typed in your location bar.  

I have Google (http://www.google.com) specified as my home page, and this
problem occurs most often when I quickly Ctrl-N to open a new window, then Alt-D
to type in an address in the URL bar in quick succession.  Half-way through
typing in my address, the Google page finishes loading and the cursor jumps to
the Google search box, resulting in my having half my url in the location bar
and half of it in the Google search box (and most of the time my hitting enter
at the end of this and doing a google search for the second half of the url,
that I never intended to do).  

It looks like this also occurs on loading http://www.alltheweb.com/ and
http://www.altavista.com.

Reproducible: Always

Steps to Reproduce:
In rapid succession: 

1.Navigate to a page that has a text box specified as an initial start position
for the cursor.  (such as http://www.google.com)
2.Position the cursor in the URL bar and begin typing a url(you usually need to
use alt-d or ctrl-l to do this quick enough)

Actual Results:  
In the midst of typing in your URL, the cursor will jump to the initial input
box on the page, messing up the URL you were typing.  

Expected Results:  
Kept the cursor in the URL bar while you were typing a URL there.

Comment 1

14 years ago
Confirming on a 20031220 Linux CVS build.
Blocks: 140346
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Comment 2

14 years ago
Confirmed on Win32, OSX, and Linux CVS builds as of December of 
2003.

Comment 3

14 years ago
This is duplicate of bug 125282, please resolve appropriately.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 125282 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

11 years ago
No longer blocks: 140346
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.