Page scrolls to the top after changing the character set

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Vladislav Duma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; ru-RU; rv:1.5) Gecko/20031006
Build Identifier: Mozilla/5.0 (Windows; U; Win98; ru-RU; rv:1.5) Gecko/20031006

When the character set of a page is changed via View -> Character Set -> smth,
the page automatically scrolls to the top.

Reproducible: Always

Steps to Reproduce:
1. Load any webpage that is long enough (e. g. http://mozilla.org/releases/)
2. Scroll it manually down to the bottom.
3. Change the character set via menu View

Actual Results:  
The page has been scrolled to the top (and I need to scroll it back if I want to
continue reading).

Expected Results:  
The page scrolls automatically to the position where it was before changing of
the character set, just like with simple reload.

Note that it's not a dup of the bug 17888, since the reloading of a webpage
doesn't scroll it up!
(Reporter)

Comment 1

15 years ago
Sorry, a typo: I meant bug 17889...

Comment 2

15 years ago
Confirming on a recent Linux CVS build.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
If you confirm on a different OS, remember to change the field :-)
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 4

14 years ago
Perhaps this bug is related to bug 64926.
Product: Browser → Seamonkey

Comment 5

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
(Reporter)

Comment 6

9 years ago
I tested the issue on the first beta (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1), the bug is not reproducible any more.
Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.