Closed Bug 229033 Opened 21 years ago Closed 21 years ago

downloading IMAP message attachment stalls

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neb, Assigned: Bienvenu)

Details

Attachments

(3 files)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

I am unable to download a specific message attachment using Mail (and also 
using Thunderbird 20031219). All other messages download fine, but this 
specific one's attachment always causes the download to hang. There is nothing 
special about the attachment, ~80kb gzipped tar file of an Mac OS X application 
(I'm running winxp).

Reproducible: Always

Steps to Reproduce:
1. Do any action that causes this attachment to be downloaded (view, save, or 
move the message from the folder)

Actual Results:  
Download stops around 425 bytes into the file, indicactor freezes. Clicking 
stop aborts the download, but nothing more can be received from the server 
until restart.

Expected Results:  
Download the attachment.

Server uses SSL (but not secure authentication). I have tried this with both 
Mozilla Mail, and Thunderbird, versions 0.3 till 0.5a (20031219). I am keeping 
this message on the server in case there is some other test that need be done.
Running winxp pro sp1, on 1.2GHz PIII, 256MB RAM.
This is the log up to the point when it stalls.
From the log, it looks like the attachment is one long line, which is really
poor behaviour on the part of the mail client/server. Can you send me the same
message, with that same mail program (blitzmail?) to bienvenu@fastmail.fm, so I
can try it? 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Forwarded the mail. I can't use Thunderbird to download that message from my 
sent mail, so there must be something special about the attachment.
My mail server seems to be sending all attachments as one long line, but 
outlook express has no trouble downloading the problem message, and Thunderbird 
works for all other messages.
Attached patch proposed fixSplinter Review
make the pipe infinite, so we can handle arbitrary long lines.
Comment on attachment 138660 [details] [diff] [review]
proposed fix

Darin suggested this approach, and it does work.
Attachment #138660 - Flags: superreview?(mscott)
Comment on attachment 138660 [details] [diff] [review]
proposed fix

thank you darin :)
Attachment #138660 - Flags: superreview?(mscott) → superreview+
fix checked in.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: