"Undo Delete Message" creates duplicate, leaves copy in trash

RESOLVED DUPLICATE of bug 59688

Status

MailNews Core
Networking: IMAP
--
minor
RESOLVED DUPLICATE of bug 59688
14 years ago
9 years ago

People

(Reporter: Josh Kelley, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

When deleting a message from an IMAP mailbox, when the option "When I delete a
message" is set to "Move it to the Trash folder," undoing a delete message
operation creates a second copy of the message (one copy in the Trash folder,
one copy in the original folder).

Reproducible: Always

Steps to Reproduce:
1. Set up an IMAP account with "When I delete a message" set to "Move it to the
Trash folder."
2. Delete a message.
3. Go under the Edit menu and choose "Undo Delete Message."

Actual Results:  
Two copies of the message - one in the original folder, one in the Trash folder.

Expected Results:  
The message should be moved from the Trash folder to the original folder.

Updated

14 years ago
Severity: normal → minor
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
I confirmed this bug in beta 1 of Thunderbird 1.5.  It also occurs when moving a
message from one folder to another then undoing the move - the message reappears
in the source folder, which it should, but a copy remains in the destination
folder, which should not happen.

Comment 3

11 years ago
have you had any other issues with trash?

possible variations - bug 323875, bug 209189
Summary: "Undo Delete Message" creates duplicate message → "Undo Delete Message" creates duplicate, leaves copy in trash
(Reporter)

Comment 4

11 years ago
I don't recall any other issues with trash, and I'm not seeing either of the bugs that you link to.

As I (tried to) explain in comment 2, the problem isn't specific to the trash.  If I move an email from one folder to another then undo the move, the message reappears in the source folder, but there's still a copy in the destination folder.

Comment 5

10 years ago
I'm seeing this also. But perhaps it's due to multiple mail clients from multiple PCs.  I have yet to test that theory.

Josh, Does bug 59688 sound like the same issue?  Do you have multiple clients open?  

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 59688
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.