Progress-meter is not updated while copying components to disk

VERIFIED FIXED

Status

()

Firefox
Installer
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Frederic Bezies, Assigned: Brian Ryner (not reading))

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking0.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-aviary1.0)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031220
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031220

All is in the summary. I grabbed 0.8 branch source, build it (see .mozconfig in
additional details), build installer following Ben Goodger instructions.

But when installer copies components to disk, the progress meter is empty.

Reproducible: Always

Steps to Reproduce:
1.Grab 0.8 sources
2.build them and installer too
3.launch install
4.look at progress meter while copying components.

Actual Results:  
progress meter stays blank.

Expected Results:  
progress meter filled :)

I am building 0.8 Firebird with installer on a WinXP-Sp1 computer, with MSVC++ 6.0.

I am using a classic .mozconfig :

"export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1

ac_add_options --disable-composer
ac_add_options --disable-debug
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --disable-tests
ac_add_options --enable-crypto
ac_add_options --disable-profilesharing
ac_add_options --enable-optimize='-O1 -G6'
ac_add_options --disable-shared
ac_add_options --enable-static
ac_add_options --disable-pedantic

ac_add_options
--enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector"

NB : I tried to see if enable-optimize line was guilty. Using a simple
ac_add_options --enable-optimize instead of ac_add_options
--enable-optimize='-O1 -G6' changed nothing.

Comment 1

14 years ago
Confirming in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040526 Firefox/0.8.0+ Aviary build.  Everything gets copied ok, but the
progressbar shows no progress whatsoever.
(Reporter)

Comment 2

14 years ago
asking for 0.9? blocking.

also asking for 1.0? blocking.
Flags: blocking1.0?
Flags: blocking0.9?

Comment 3

14 years ago
This showed up again in Aviary branch firefox: Mozilla/5.0 (Windows; U; Windows
NT 5.0; en-US; rv:1.7) Gecko/20040526 Firefox/0.8.0+ with the installer build
(did not test .zip build)

Comment 4

14 years ago
*** Bug 244852 has been marked as a duplicate of this bug. ***
Thunderbird installer also has the same problem the last days.
Flags: blocking1.0?
Flags: blocking0.9?
Flags: blocking0.9+
Hm, so it looks like the file sizes for components are not being filled in
properly in config.ini when it is generated. I'm assigning this to bryner when
he gets back. We should have a fix in the next couple of days. 
Assignee: bugs → bryner
Bryner fixed the build script issue this afternoon. Marking fixed for him.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Actually, this was still busted. I just properly fixed it branch and trunk.

Comment 9

14 years ago
Verified fixed on the trunk, 20040604 PC/WinXP.

Updated

14 years ago
Whiteboard: fixed-aviary1.0

Comment 10

14 years ago
*** Bug 244853 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.