misleading message whether download completed successfully or aborted prematurely

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
10 years ago

People

(Reporter: imbaczek, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031206 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031206 Firebird/0.7+

My connection is rather unstable, but the summary says it all, really. I'd also
like to see the overwrite dialog extended with "Append" button, and aborting the
download if the server doesn't support resume.

Reproducible: Always

Steps to Reproduce:
1. download some file
2. make it fail prematurely
3. PROFIT!!!

Actual Results:  
"All downloads were completed successfully." (or something.)

Expected Results:  
"The download 'http://example.com/foobar.baz' stopped prematurely. You can click
'Resume' in the download manager to try to resume downloading."


The world would be a happier place :)

Comment 1

15 years ago
Marek,

How do you make the download fail prematurely (or are you talking only about
'random' failures)?  

Clicking cancel responded correctly and offered to resume or remove the
download, and did not show me the 'all downloads were completed successfully' box.
(Reporter)

Comment 2

15 years ago
Tough job. It may be that it's not a Firebird issue after all. It
may be a broken transparent proxy closing a socket prematurely. (Yes,
my ISP sucks and won't do anything about it.) Besides, Cancel on a
server supporting Content-Range did not give me an option to resume, only
to retry. (The server in question is olimp.vlo.ids.gda.pl, try
http://olimp.vlo.ids.gda.pl/~endrju/studniowa%2004/zdjecia.zip)

In any case, I think the correct solution would be to compare
downloaded size and reported size after the socket gets closed and act
accordingly if they differ (silently resume or display an error
message.) I'm pretty sure that the server reported the size correctly
- I've used Flashget[1] after FB didn't download the whole file and it
split the download just fine.

Flashget-like download manager has been on my Mozilla wishlist since
forever :)

[1] http://www.amazesoft.com/

Comment 3

15 years ago
Can you try this again with Firefox 0.8? It no longer says that the download
completely successfully if it failed, and pops up an error to this effect and
says that the download has failed in the download manager.

If the problem is fixed for you in Firefox 0.8 (please do a clean install and
use a new profile) then please resolve this bug as invalid. If not, then please
comment and let us know how its still broken.

Thanks.
QA Contact: aebrahim
(Reporter)

Comment 4

15 years ago
(In reply to comment #3)
> If the problem is fixed for you in Firefox 0.8 (please do a clean install and
> use a new profile) then please resolve this bug as invalid. If not, then please
> comment and let us know how its still broken.

The first problem went away - a dialog box appeared along a 'Failed' download
status. The second one also works, sort of. The download manager lacks a
'Continue' option - I have to click on a link to get it going (Retry makes
Firefox, well, retry.)

I'm marking the bug as invalid nevertheless.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.