mangled email address if address book name contains a blank space

RESOLVED WORKSFORME

Status

Thunderbird
Address Book
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Fred Wedemeier, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

I have an address book entry with 
    Name First:  Renesas TechSupport
and
    Internet Email: Techsupport.rta@renesas.com
all other fields blank

Adding this entry to an email generates 
    To: "TechSupport <Techsupport.rta"@renesas.com>

Examining the source of the bounce message shows failed address:
<ÿòÿÿÿžÿÿÿòÿÿÿžÿÿÿñÿÿÿŸÿÿÿòÿÿÿŸÿÿÿòÿÿÿŸÿÿÿóÿÿÿžÿÿÿóÿÿÿžÿÿÿóÿÿÿžÿÿÿôÿÿÿžÿÿÿôÿÿÿžÿÿÿôÿÿÿžÿÿÿõÿÿÿžÿÿÿ\>
  
and the text of the bounced message shows
    To: "


Reproducible: Always

Steps to Reproduce:
1. Open address book and select entry described above
2. Click Add to To:
3. Attempt to send mail

Actual Results:  
Bounced message due to malformed address described above.


Expected Results:  
properly format the address.


Removing the blank from First Name, ie. making it
  RenesasTechSupport causes a properly-formatted address to be generated.

Comment 1

14 years ago
I've justed tested this in Thunderbird 1.0, and the address was added without
any problems. Can you still reproduce this in a recent version?
URL: na

Comment 2

13 years ago
Over 1 month with no response from reporter -> WFM. Please reopen if bug still
present in a recent build.

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.