Can't scroll with mousewheel when a link in an overflow:hidden div has focus

VERIFIED DUPLICATE of bug 97283

Status

()

Core
Event Handling
--
minor
VERIFIED DUPLICATE of bug 97283
15 years ago
14 years ago

People

(Reporter: shadytrees, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+

Going to http://dailyrotation.com/ and middle clicking any link (to load a new
tab in the background) will shift the focus to that link and will make mouse
wheel scrolling disabled until focus is shifted to the page, and not the link.
Testing in #firebird has shown that this occurs with a 0.8 branch build
(Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031218 Firebird/0.7+),
a trunk build (12-16), a trunk Mozilla build (12-20, I think), and a Firebird
trunk build by noririty. This, however, does not occur on Mozilla Firebird 0.7.
All builds were tested with a brand new profile.

Reproducible: Always

Steps to Reproduce:
1. Go to dailyrotation.com.
2. Middle click on a link to open it in a new tab in the background.
3. Try to scroll down with a mouse wheel.

Actual Results:  
Nothing.

Expected Results:  
It should've scrolled down, like it has done previously.
(Reporter)

Comment 1

15 years ago
Noririty tested the Mozilla build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/2003122009
(Reporter)

Comment 2

15 years ago
Also: This bug does not occur with Mozilla 1.5
Also: Tested with Win98SE and WinXP.

Comment 3

15 years ago
May also be worth noting that when I have tabs set to open in the foreground I
can wheel scroll on the story I opened in the new tab, but after closing this
tab, returning me to the dailyrotation tab, the wheel does not function there
until clicking within the document.

WinXP
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031222

Comment 4

15 years ago
Odd... this is the first time I've seen this happen--usually it's the exact
opposite where I can't scroll with the keyboard, and it affects all pages
/except/ one.

OS -> All (I'm on Linux)

Notes: it only affects some links on the page (namely, not the ones next to New
Additions or Current Top Headline), it really /is/ focus problems since tabbing
to the links causes the problem too.
OS: Windows 98 → All

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: [site-specific apparently] Middle-clicking a link to open it in a new tab to load in the background disables mouse wheel scrolling due to focus problems → Can't scroll with mousewheel when certain links have focus

Comment 5

15 years ago
Created attachment 138323 [details]
testcase based on dailyrotation.com

The problem is the overflow:hidden div.  For an overflow:hidden div where part
is actually scrolled off, it makes sense for wheel scrolling to scroll the div,
at least until you get to the bottom of the div.  But this overflow:hidden div
doesn't have a height set, so it looks like a normal div.

Updated

15 years ago
Keywords: testcase
Summary: Can't scroll with mousewheel when certain links have focus → Can't scroll with mousewheel when a link in an overflow:hidden div has focus
(Reporter)

Comment 7

15 years ago
This bug has vanished mysteriously for me on the official 0.8 release:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
(Reporter)

Comment 8

15 years ago
Er, lack of activity, and that it's vanished -> WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 9

15 years ago
I still see this bug at dailyrotation and at the testcase.  Reopening.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040306
Firefox/0.8.0+ (stipe)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

15 years ago
Aack, you're right. Should've tested it with a new profile. AiO 0.9.7 seems to
make this bug go away.
I can reproduce the problem in 2004-08-05-10 trunk Linux, but not in a debug
build with the patch for bug 97283 in it (should be fixed in nightlies shortly).


*** This bug has been marked as a duplicate of 97283 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
No longer depends on: 97283
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.