Impossible to configure proxy to get no proxy for a range of IP address

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Simon Ruel, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I need to use a proxy but I have a lot of machines that are on my intranet and
they have no domain suffix.  In Internet Explorer I can configure the no proxy
for using an range of IP like that "localhost;127.0.0.1;232.*;154.26.*" but this
is impossible to do with Firebird.  It is impossible regarding my intranet to
configure using domain names (mydomain., otherdomain.) except if I add two
entries for each of my servers, one for the hostname and the other for the IP
address to make sure it won't use the proxy for it.

Reproducible: Always

Steps to Reproduce:
1. Set up an Intranet with many machines using different hostnames (ex:HOST1,
HOST2, HOST3, etc.)  each Hosts have an IP address starting with the same prefix
(156.23.43.10 for HOST1, 156.23.43.20 for HOST2, etc.)
2. Set up a proxy and try to configure your firebird for not using the proxy for
all the machines of your intranet.
3. It is impossible to just add to the no proxy for 156.23.43.* you must add two
entries for each of your hosts, one for the hostname the other for the IP address



Expected Results:  
Add a feature like in IE that allows to enter in the no proxy for section a
range of IP address like that "156.*"
simon: does this work in a current mozilla build?  trying to figure out if its a
UI issue as bug 80918 suggests the backend for this exists
(Reporter)

Comment 2

15 years ago
The bug Im talking about is exactely what is describe in bug 80918 (Sorry for
bug duplication) I dont try if if wirk in the latest mozilla build but I don't
think so but I have tried with the Firebird nightly build on december 22 and it
was not working (156.* in the "no proxy for..." section)
Simon, please get a build from
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/ and test,
if you still see this, we need to get this properly assigned.
(Reporter)

Comment 4

15 years ago
I haved downloaded the latest version dated from 2004-01-21 of mozilla (1.7a)
and it still not working.  I think something must be fixed!  
moving
Assignee: blake → darin
Component: Preferences → Networking: HTTP
Product: Firebird → Browser
QA Contact: mconnor → httpqa
Version: unspecified → Trunk
as far as I can tell, this is the format you should use:
  ipaddr[/mask]:[port]

so instead of this:
"localhost;127.0.0.1;232.*;154.26.*"
you should use:
localhost; 127.0.0.1; 232.0.0.0/8; 154.26.0.0/16
(Reporter)

Comment 7

15 years ago
OK if I use it this way: "localhost; 127.0.0.1; 232.0.0.0/8; 154.26.0.0/16" it
fix the problem when I am using only IP address to connect to my servers but if
I try to connect using the hostname (machine name) without the domain: Mozilla
try to resolve my address using the DNS first and fail.  Internet explorer have
a different behaviour, when I type an hostname (machine name) it first try to
resolve it using the hosts file (/etc/hosts on unix machine,
%SYSTEM_ROOT%\system32\driver\etc\hosts under win2k) and if there is an IP
mapping in the hosts file the the proxy rules are applied on this IP (found in
the hosts file using the machine name).  If there is no mapping in the hosts
file, it try to resolve it using the DNS.

This means if all my machines (in the intranet) are mapped in the hosts file
(This is the case when using NIS domain) using IE I can reach all of then using
IP, machine name, hostname or hostname + domain if proxy setting within IE is 
as simple as "localhost;127.0.0.1;232.*;154.26.*" but using Mozilla or Firebird
I can only reach my machine using IP if I configure the proxy like
that:"localhost; 127.0.0.1; 232.0.0.0/8; 154.26.0.0/16" and if I want to access
my machine (in the Intranet) using machine name or hostname I must add every
hostname of every machine in the proxy setting (some of my machines have up to 4
differents hostname is start to be complicated.) 

THINGS TO DO
I think there must be an attempt to resolve the name using the hosts file first
and then If a mapping is found within the hosts file, apply non proxy host rules
on that IP, otherwise (not resolve wihtin hosts file) try to resolve the name
using DNS.

Comment 8

15 years ago
The remaining problem you have is actually two problems:

bug 91587 and bug 136789.

Comment 9

14 years ago
Reporter, if you agree, please resolve this bug as a duplicate of one of the
above mentioned bugs.

Comment 10

14 years ago
Marking as WFM. For the remaining problems see the bugs in comment 8. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 11

14 years ago
V/WFM, best resolution for now.

The noproxy code is in C++, the PAC code in in JS, guess which I can fix, and
which I'm learning?

We need to fix the no-proxy for hostnames bug next.
Status: RESOLVED → VERIFIED
QA Contact: core.networking.http → benc

Updated

13 years ago
Component: Networking: HTTP → Networking
You need to log in before you can comment on or make changes to this bug.