entering user_pref("browser.cache.memory.enable", false); in prefs.js/user.js breaks this site.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: robmersel, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.8 [en] (Windows NT 5.1; U)
Build Identifier: Mozilla/4.8 [en] (Windows NT 5.1; U)

This page doesn't display at all when 

Reproducible: Always

Steps to Reproduce:
1. enter the line user_pref("browser.cache.memory.enable", false) in user.js
2. run firebird 0.7+ and go to url:www.tweakers.net


Actual Results:  
the site doesn't show

however after the steps:
1. close firebird 0.7+ 
2. remove or comment the line user_pref("browser.cache.memory.enable", false) in
prefs.js
3. run firebird 0.7+ and go to url:www.tweakers.net 
the site is shown again.

Expected Results:  
I expect Mozilla/Firebird not to use memory caching when retrieving sites. It
appears that this memory space is re-used for things in the DOM (just guessing
here :-) and not a 'real' cache'. The engine can't find in the DOM what it was
trying to do. And gives up. Guessing it is caused by 'efficient' memory use.

Workaround: don't use user_pref("browser.cache.memory.enable", false)

Comment 1

15 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040128
Firebird/0.8.0+

Rob, I just tried to reproduce this problem and I couldn't.  I did notice that
this site is very complicated and slowed down my computer while it was loaded. 
Maybe you didn't have enough memory for it?

Can you try a newer Firebird build from
ftp://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-trunk/ and try to
reproduce this problem.  Please report back on your status.

Comment 2

15 years ago
Tested again on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040217 Firefox/0.8.0+  still WFM.

I'm resolving this as WFM since the reporter has not replied in 2 weeks.

Reporter: if you try this bug with a newer Firebird build from
ftp://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-trunk/ and you are
still experiencing this problem, please reopen this bug and provide more
information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

14 years ago
i have the same problem with firefox 1.0 and Windows XP
also happens on www.lvb.de and www.mdv.de

(and i have 512 MB RAM, so that's not the problem)
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.